No sound through HDMI - Ubuntu Mate 20.04 / Pi4

I've installed Ubuntu Mate 20.04 on my Pi 4, and I don't seem to have HDMI sound.

I've tried ScummVM and YouTube and neither work. Looking at other posts, I've added the below to my usercfg.txt, from reading other threads they seemed to help some people.


But still no joy.

I have the following in my config.txt by default:


Any help would be appreciated. I have sound working on RetroPie and Raspian.

The monitor I am using is a Samsung 22 inch.

On ubuntu sound preferences, did you select hdmi output? Some trivial, never know...

Trivial, but you are right. There was no option for HDMI Output though.

There is a section of Sounds Preferences called Output, where you can select two identical looking "Built-in Audio Stereo" options.

One has Connector set to "Analog Output", the other has "Headphones" - selecting "Analog Output" fixed the HDMI issue.

I've found that, by default i get no sound even tho' I'm connected to the pi hdmi1 port (nearest to the power socket.
To get it working I select sound preferences (from the volume icon on top bar), select 'hardware'and perform speaker test.
When that gives no output,select the other option, and repeat the test - should get sound now.
You may also need to select the other device under the output tab.
Don't quit preferences, or you lose the setting!.
It will also be necessary to repeat after a reboot.
I don't yet know how to make this selection default!

1 Like

Yeah I have to do exactly the same! I haven't worked out how to default yet either... Let me know if you work that out!

by default sound comes out on headphone jack

what i have done because i don't use headphone jack;
disable headphone jack
you can do it in soud setting: hardware tab put the 1st one off (this is the headphone jack)

Result: one HDMI stay's active

Test: reboot and sound comes out on HDMI

My system
RPi4 4 Gb
Ubuntu mate 20.4 raspi 64 bit
OS 5.4.0-1015-raspi

just give a try
if later on you want to use sound on headphone jack you can enable it again


To easily switch my audio output, I use the following tool:

sudo apt-add-repository ppa:yktooo/ppa -y && sudo apt-get update && sudo apt-get install indicator-sound-switcher -y

Happy to try anything that might help but I get the following when I try to install:

Fetched 483 kB in 4s (111 kB/s)
Reading package lists... Done
E: Failed to fetch 404 Not Found [IP: 2001:67c:1360:8001::22 80]
E: Failed to fetch 404 Not Found [IP: 80]
E: Failed to fetch 404 Not Found [IP: 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

Edit: Tried to install it using sudo apt install, which worked. However it doesn't seem to open when I click on it in Ubuntu Mate now.

This error is not about the command to install it. You may have some error in the sources of your system. I will help you to fix this. Can you show us the output of:

apt-cache policy | grep http | awk '{print $2 $3}' | sort -u
ls /etc/apt/sources.list.d | egrep -v "(^#.*|^$)"
sudo apt update

About the tool indicator-sound-switcher, to open it, search it in the Menu of apps. To start it with the system:
Control center > Startup Applications > Add entry to this command: indicator-sound-switcher

1 Like

Is it possible with the tool indicator-soud-switcher making HDMI default on login or every time i login i have to use the indicator-soud-switcher ?

Yes, this tool keep the last settings audio output. Only if device HDMI is on.

I'm away from my Pi at the moment, but I will look into this when I am able to. Thank you for taking the time to respond.

I can currently find indicator-sound-switcher in the Apps Menu but it simply doesn't open. Nothing happens when I click on it (although if I put it onto my Desktop, I do get an "Opening Sound Switcher Indicator" entry on my bottom Panel for about 10 seconds, which then disappears). It is in my Startup Applications, but again, I just can't seem to see it open anywhere on screen.....

Edit: here is the output that you asked for:

When open indicator-sound-switcher, there is no window, just an icon appears in notification aera, near the sound indicator. Click on the icon of indicator-sound-switcher and select HDMI output.

About the error in sources:

sudo apt update ...
E: Failed to fetch 404 Not Found [IP: 80]
E: Failed to fetch 404 Not Found [IP: 80]
E: Failed to fetch 404 Not Found [IP: 2001:67c:1360:8001::22 80]

It seems your system are not able to reach the adress. May be you should switch the repository to the default? I don't know.

1 Like

How would I go about switching the repository to the default? It seems weird that anything is non-default really, I haven't looked to change anything in this area.

Yes. This worked fine for me. Thanks. Sound coming through monitor now.