No sound through the speakers but HDMI is working

hi all
this is my first post and new to Linux.

i’m using a chrome book, hp14 g4,
completely removed chrome os for Linux
ive installed a few distros all the same no sound lubuntu, xubuntu, phoenix os, settled on mate

my problem is i’m having sound issues, no sound through the speakers or headphones,
but i do get sound through HDMI on a second screen,

i cant select the analog sound in the sound settings only HDMI

ive followed lots of tutorials over the last 2 weeks on trying to fix it but nothing has helped,
uninstalled/reinstalled, alsa, pulse audio,

i read somewhere i could be the kernel, but i cant update it past 4.15, think the latest is 4.18,

i’m at a total loss and don’t know what to do to fix it, i’d really appreciate it if someone could point me in the right direction, thanks in advance

check if just ALSA audio works before trying to check Pulseaudio

Use command aplay -l
I would expect HDMI to be listed first as Device: 0 (default)
And Analog shown as Device: 1

Use command alsamixer --card 1 --view Playback
check outputs are unmuted (OO not MM) and levels not on zero
Use a music player that can select ALSA Devices for direct playback to check if sound is working

1 Like

hi nikgnomic thank you for your replay

yes analog is device 1
in alsamixer my speakers or headset were not muted, but there were a few other settings in there that was,
i un muted some with no effect
untill i un muted EXT SPK, which outputed a hissing sound, a bit like an old tv not tuned into the channel properly,
also the analog sound devices is now select able in the sound preferences,
but still no audio, mp3 or youtube
what media player would be good that uses the asla device,

I use Audacious as music player source
in Audio settings select ALSA instead of Pulseaudio and click ‘Settings’
For testing your device 1 pick items on list starting like this (with name of device after it):
PCM Device: hw:1,0…
Mixer Device:hw:1…

that should play sound, but not after fixing next part

To get sound working in Pulseaudio:
pavucontrol --tab 5
Configuration window that opens will show:
1st device (HDMI) set for playback
2nd device set to ‘Off’ - change to ‘Analog Stereo Playback’
(change to Duplex instead of Playback later if also want microphone or other audio input)

Change to 1st tab Playback and check to see if any sound playing
If HDMI is still on may need to change sound output from digital to analog output

1 Like