Not able to use VirtualBox

I got a Dell Laptop dual booting Windows 10 (for the family) and Ubuntu Mate 16.04 LTS for me.
I am having trouble running VirtualBox.
I have installed it and it seems to be OK.
But when I try to start a virtual machine I get this error;

RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing


may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn’t match the version of the user

I suspected that it was the UEFI, but I have tried to disable this, with no result.
I can add, thst I tried to install VirtualBox on the Windows 10, and it work there?

I have tried several commendline commands I found on DuckduckGo, but with no luck.

Does anyone know what to do?

Best regards

found some subjects about this : (google search)
II do not have ability to give real deep help, but at least i can ask how did you installed virtualbox ?
I personally always do it from synaptic package manager - just kind of habit i guess.

Great, thanks for your reply.
I used one of the links you sendt, and made the folloewring in the terminal;
sudo dpkg-reconfigure virtualbox-dkms
sudo dpkg-reconfigure virtualbox
And then;
sudo rmmod vboxnetadp vboxnetflt vboxpci vboxdrv
sudo /sbin/rcvboxdrv setup

And it seems to work - so thank you a lot.

Now I will start trying all sorts of different distros :slight_smile:

Best regards

I am glad that worked for you. Right now i am using Ubuntu Unity so i couldn’t event try it out !
Anyway, it is allways good to share some things here ! :blush: