Nvidia 304 driver install in 18.04

The nvidia 304 driver is no longer supported in your 18.04 repositories. My computer crashes without this driver. I downloaded 304.137 from nvidia. How do I install this?

1 Like

Hi Rylan

I had the same problem in the Beta 2 release so reverted back to 17.10 hoping it would be fixed by the time the final release was out.

Have you tried changing the download server to main or your country’s server and then running additional drivers again?

If nothing comes up…I hope as you… that there is another way…would hate to be shut out of this upgrade due to the 304 driver not being supported anymore…

Here I am, resurrecting an otherwise useless 2006 iMac 24inch. I was able to overcome the 32bit EFI, but this is very disappointing. I wish Nvidia were more open source friendly. One is sometimes given hardware, so just avoiding nVidia isn’t always an option.

Even though the 304 has been relegated to end of life by Nvidia it is still available to install in versions 16 and 17…why not in 18.04?

They’re all currently supported versions of the OS. If it’s for some remote possibility of a security threat that it was dropped in 18.04 why expose versions 16 and 17 to this threat while keeping 18 safe?

Maybe some one can explain the logic behind this decision. Seems rather inconsistent to me…

I’m currently using it in 17.10 and it works flawlessly. If it makes a machine work then let it be available with a disclaimer and let the user decide.

17.10 will be pulled next month…will be downgrading to 16.10 to keep things running with UM for a while longer.

Seems odd though that an OS downgrade is the only way to maintain support and the availability of the 304.137 driver… should be available for all versions or not at all.

There seem to be 304 drivers for both Bionic and Cosmic on the graphics-drivers ppa. I don’t have any hardware to test it handy, though, but might be worth a look at.

Hi grenouille

Thanks for that link…I’ll be attempting a fresh install of 18.04 in the coming days and will be trying your suggestion…I appreciate the feedback…thanks.

No problem. Let us know how it works out for you.

Hi grenouille,

Did a fresh install of 18.04 over the weekend and no need so far to install the Nvidia 304 proprietary driver as the Nouveau driver seems to be doing just fine so far.

Prior attempts to install the 18.04 Beta with the Nouveau driver had produced numerous faults and screen gibberish rendering the system unusable, that is no longer the case. I did notice a few Nouveau driver fault entries in the Kernlog but no instability issues relating to them.

So it looks like the Nouveau driver has improved support for these older Nvidia GPU’s since the 18.04 beta release…which is great news!..so I’ll cross my fingers and keep riding with this one.

Thank you again for all your help and suggestions…greatly appreciated.

No problem, that’s what everybody’s here for. Glad it’s working out for you.

Hi grenouille,

Well it was good while it lasted…problem resurfaced this morning 4 days after a clean install. Nouveau driver faults creating a distorted screen, jagged diagonal lines.
Will try the ppa solution you proposed…

Hi grenouille

1- Followed the procedure for adding the ppa.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

2- Ran driver update and the 304.137 driver shows up in the list.

3 -Select the 304 by clicking the radio button and then click apply changes.


  • After clicking “Apply Changes” the check mark next to the 304 driver jumps back to the Nouveau driver option, can’t make it stick.

  • Tried changing the server to main from the Canadian…same thing happens.

Any insight into how to make this selection stick?

Installing Nvidia drivers using the PPA method is vastly easier than installing Nvidia drivers under Windows or via the GUI avaliable under Ubuntu MATE. Also, forget the .sh method of installing Nvidia drivers, it’s an outdated nightmare of a process.

Open a terminal window using [ctrl]+[alt]+[T] and copy/paste the following:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-304
sudo apt install nvidia-settings

Once this is done, reboot.
Once the system has rebooted open the Nvidia X-Server Settings in the Ubuntu MATE Control Center and make sure you’re running the correct drivers.

Hi Bulletdust

Thanks for those instructions. Gave it a few attempts but was not able to get it installed. After the third instruction “sudo apt install nvidia-304” received this message:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
nvidia-304 : Depends: xorg-video-abi-11 but it is not installable or
xorg-video-abi-12 but it is not installable or
xorg-video-abi-13 but it is not installable or
xorg-video-abi-14 but it is not installable or
xorg-video-abi-15 but it is not installable or
xorg-video-abi-18 but it is not installable or
xorg-video-abi-19 but it is not installable or
xorg-video-abi-20 but it is not installable or
Depends: xserver-xorg-core but it is not going to be installed
Recommends: nvidia-settings (>= 331.20) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Not sure what all this means…maybe you have an idea of what might be going on…thanks for any insight.

Looks like there’s a bug filed on it: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/+bug/1763648. Posts #5 and #6 have some other suggestions. Wish I had an easy answer for you.

Thanks just the same…I appreciate all the help. Nothing really to do it seems…looks like support for 304 has been dumped by 18.04 all together. Unmet dependencies…probably means it has no way to communicate with the display server.

Was looking good for a while there. Don’t usually like giving up on things like this…but this one feels pretty much baked into the cake with the dependencies thing.

I guess I’ll be installing16.10 in the interum…did the 17.10 thing and it’s reaching it’s end of life so figuring I can squeeze a few more months out of 16.10 before it’s dropped…then probably off to some other distro.

Thanks again.

This is one of the reasons I refuse to update from 16.04 to 18.04 LTS until the first point release. Having said that I am running a 980Ti so I’m running the latest Nvidia drivers.

Have you tried:

Sudo apt-get install -f

To repair dependamcy issues?

A wise decision to stick with the true and tested. Thanks for that suggestion I’ll give that sudo command a try.

I’m thinking in my case things worked in 17.10 so what has changed in terms of the video driver installation issue. The only thing I can think of is that from a display server stand point 17.10 was running on Wayland and the new LTS employs Xorg.

When executing the “sudo apt install nvidia-304” command most of the error messages that returned were in referring to the xorg video abi.

Could that be the issue? and if so is there a way to switch back to Wayland?

The Nvidia drivers don’t support Wayland, Nvidia drivers support Xorg only. Are you sure that the 304 driver supports your card?

Yes I’m sure the 304 is the right driver for the card (Geforce 6150). I was able to install the 304 driver under 17.10 which I believe uses Wayland by default.

The 304 driver showed up when I ran additional drivers accessing the Canadian server.

I had to cycle through the selection process about 3 or 4 times before the nouveau driver was replaced by the 304.

Once installed the system worked flawlessly and the Nvidia X-server settings that you mention became available.

With 18.04 I had to add the ppa before it showed up in additional drivers and every time I selected it, it defaulted back to the nouveau driver.

The command line installation method returns error messages with reference to xorg.

So just a hunch that it could be something to do with the display server change between 17.10 and 18.04.

Just an update to the 304/Nouveau driver saga. Nouveau driver finally crashed my recent installation of 18.04.

Had experienced numerous smaller crashes over the last ten days but was able to get it stable and running with a few reboots.

It would hold for a few days then act up again. This time the reboot did not work, grub screen pops and I could have spent the time trying to learn how to get up and running again but decided to get away from 18.04 and give 16.04.4 a try.

So far so good. I will try to hold off from installing the Nvidia 304 driver for now which by the way was instantly available from the additional drivers (really nice! wish 18.04 could have done this).

Anyway I’ll be running the Nouveau driver for a while to see if it misbehaves on this version of UM…just for curiosities sake.

Did notice some nouveau faults in the kernlog but no inconsistencies system wise except for some uneven movement as I’m typing this post at the moment and using the arrow keys …just noticing it now…guess I’ll be moving to the 304 sooner than I thought…