Nvidia 304 driver install in 18.04

No that is the only procedure I haven’t tried. I understand it is a bit more involved.

I wanted to give it a whirl but some one previously mentioned that it may not be installing due to the newer version of the Xorg server.

IT has been over a month and I have been very happy with my purchase. xfx amd radeon r5 220 2gb ddr3. 49 bucks Best Buy, no more screen tearing, no more proprietary software.

For testing purposes do you think it would be possible to to install 304.137 driver from Nvidia directly using a live usb session of 18.04?

Try to install v304 driver on Ubuntu and it will fail due to xorg version
try to downgrade to older version of xorg and will be more dependencies from that need attention

If really need to keep old GPU running, consider switching to Debian that still has this driver available

I have been happy using a GT730 for a while
Get a later card version with Kepler core GPU and can use latest v396 driver

With live usb i got a kernel error on trying to unload nouveau.
You can install Ubuntu to usb and test the driver on new system. This will be slower, but suitable for testing.
Yeah! Note what the driver requires a patch for work with 4.15 kernel .

Yes moving to Debian or upgrading gpu seem seem to be only viable solutions. These options have been suggested to me before…thank you for your input nikgnomic…greatly appreciated. Love the handle by the way…is the “g” silent? lol.

So no unloading nouveau in live usb session, that’s good to know. Seems like getting the 304.137 driver working in UM18.04 just won’t be happening.

So far the wisest course of action suggested to me is to either move to Debian or upgrade my gpu.
Everything else is sort of hit and miss and most likely more miss than hit in this case…

I thank you for all your help tepik…much appreciated.

doing some research into this myself, i came across what i believe to be the source of the issue… the only libgl (a thing xorg depends on) available in the 18.04 repos is the mesa one, which breaks the nvidia-304 driver… might try something on my own.
edit: reread some of the comments. install 17.10, enable the canonical partners repo add the graphics drivers repo to the sources list, sudo do-release-upgrade

Hi!

I have a pc with an old Geforce 6800 card and I have managed to successfully install the 32bit Nvidia 304.137 driver for it on Lubuntu 18.04; all thanks to a community patch. Here is the procedure.

Install build tools
$ sudo apt install gcc make build-essential gcc-multilib dkms mesa-utils

Download driver from https://www.nvidia.com/Download/driverResults.aspx/123708/en-us

Download patch from https://adufray.com/nvidia-304.137-bionic-18.04.patch

Extract archive, place patch into extracted folder and apply patch
$ ./NVIDIA-Linux-x86_64-304.137.run -x
$ cd ./NVIDIA-Linux-x86_64-304.137
$ patch -p1 < nvidia-304.137-bionic-18.04.patch

Disable nouveau driver and reboot
$ sudo -i
# cat << END > /etc/modprobe.d/disable-nouveau.conf
blacklist nouveau
blacklist vga16fb
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
blacklist amd76_edac
options nouveau modeset=0
END
# update-initramfs -u
# reboot

Stop x-server
Logout
Bring up terminal with Ctrl-Alt-F1, login
$ sudo -i
# service lightdm stop
# init 3

Install NVidia driver
Ignore the first warning about preinstall failing, agree to driver recompilation on kernel update and to configuration files update. Reboot.
# ./nvidia-installer
# reboot

Driver should be working now. Check with the following:
$ lshw -c video 2>&1 | grep driver
Should output"configuration: driver=nvidia"

There is one small problem though. Apparently Nvidia driver installs it’s own version of libvdpau, which does not work with mplayer. That’s why we need to forcefully reinstall libvdpau (and possibly need to do this on kernel update, because driver will recompile and reinstall it’s own, non-functioning version for this library?)
$ sudo apt --reinstall install libvdpau1

2 Likes

References: (placed in separate post because new users are allowed to only 2 links per post)
Compiling nVidia 304.137 on Ubuntu 18.04: https://adufray.com/blog/2018/06/02/nvidia-304-127-on-bionic
How to install NVIDIA.run?: https://askubuntu.com/questions/149206/how-to-install-nvidia-run

This worked.

We have an Compaq Presario V6200 (V6221EU) with nVidia Geforce Go 6150.

The issues described above indicating a faulty card is usually due to subtle driver bugs in the nouveau driver. These card are powered as nv40 by nouveau. The nouveau devs have gone through great lengths to get all these cards supported, but laptop drivers are especially difficult. Even on Windows Vista, which was provided with the laptop, I had to install ‘special vendor’ drivers to get them working.

Works perfect!! Thank you!!

I have a question, Fedorov, you put a link to the nvidia driver for the 32-bit linux system, and then give instructions to change to the extracted folder, but it shows a path for the 64 bit version…The patch referenced in adufray is for the amd-64 version, also the file referenced in nvidia repository is the 64 bit version.

How can I make it work for the 32 bit version?
Regards

Hi, guys
Anyone is able to use hardware acceleration in Firefox after installing above mentioned 304.137 drivers?
When i switch on layers.acceleration.force-enabled to true Firefox just doesn’t start, unfortunately. When ran from terminal it outputs “Segmentation fault” message.
I’ve just purged it and reinstalled back with no luck.

My system is Ubuntu-Mate 18.04.1 LTS (GNU/Linux 4.15.0-45-generic x86_64) running on AMD Athlon™ X2 Dual Core Processor BE-2400, 4Gb DDR2 RAM and Nvidia C61 GeForce 6100/nForce 405 integrated GPU.

Hi there. Got a laptop with geforce go 7400 and used this method to install 304 drivers. In the end the command
lshw -c video 2&gt;&amp;1 | grep driver
gives : configuration: driver=nvidia latency=0

but the screen is not recognised -it is 1280x800 and atm it says unknown monitor and goes only 1024x768- AND nvidia x-server is not working it says that I don't have a nvidia driver. What to do now ?

@Hasan_Aslan
Try this to get your resolution right:

For all desktop users:
I just got a GT620 on Ebay for $20. Yeah, it's old and, frankly, still crap compared to the newer cards, but it does use the 390 drivers and is a good, stable and reliable card. I noticed that there are many of that era cards for dirt cheap and they are perfectly acceptable for the older systems we've been discussing. Hell, even a GT210 will play 1080p video (mostly) and it uses the 340 driver.

I realize that, for many, budgets are tight (mine no less so) but I finally got frustrated enough that I decided that my time and blood pressure were worth it. It's up to you to make the same decision or not. If it helps, this particular system (Phenom X4 9150e, 8GB ram) has never performed better.

If you have a computer that can't run without the nvidia 304 driver, and you don't want to buy a graphics card, but want the mate desktop, then an alternative would be GhostBSD. They still have support for the 304 driver. FreeBSD still has it as well, along with NomadBSD.

The better way is to stay on Ubuntu ecosystem and reinstall Ubuntu MATE 16.04 LTS instead.
In this particular case it does not matter that it is end-of-support as a flavor.
I do so with my Nvidia 9600GT and GT425M based devices.

Sorry for bringing an old topic back from the dead. I tried all of the methods described here to install the 304 drivers on Xubuntu 18.04 with no luck. Seems something has changed yet again. I also went as far as re-installing ubuntu 16.04 and still could not install the drivers with any the fixes online. On another site it described the root of the problem being the lack of 2 symbols in the main.c file although I tried to look for an ubuntu equivalent but could not find one.

EXPORT_SYMBOL(mtrr_add);
and
EXPORT_SYMBOL(mtrr_del);

Finally a working solution, thanks for your help