Nvidia drivers messing up wireless and boot/shutdown

So I've been having trouble with getting the nvidia drivers to work properly. I'm on Ubuntu mate at the moment and any time I switch back to Nouveau through software and updates, then restart, everything is fine. But after switching to the provided nvidia driver and restarting, my wifi dongle no longer functions and I have to use this super slow powerline connection. Surely something's going on.

On a side note, boot time is about 20 seconds with nvidia drivers, and likewise over a minute for shut down. This only takes a couple of seconds on the nouveau drivers, and if anyone has any insight on that that would be great.

Also, I have a gtx 970 if that's important. If someone can help out that would be great, thanks.

Edit: OS version is ubuntu mate 16.04 LTS, if that's important.

I’ve had the same slow boot and bloody slow shutdown issue with my gtx 970 and 16.04. I’ve tried Kubuntu, Ubuntu Mate and KDE Neon (all 16.04). In every case shutdown goes from 8 sec to +2min as soon as nvidia drivers are enabled.

i called into the Linux Action Show and Noah took my question. He was aware of 16.04/nvidia issues but only advice was to go to Antergos.

Wish I could troubleshoot this. Mate is so great.

No issues like that here with a 750Ti, maybe it’s just related to the 970?

Hi Toad, I have a GTX 970 and it works flawlessly using the drivers from the welcome screen additional Drivers install. Also running 16.04.

Have a look through ‘dmesg’ in the terminal, that will give you an idea of whats taking so long to boot.

Not really a Linux master but thats where I find most of the system problems.

thanks antechdesigns

what driver version?
ssd or hd?
what processor?
how fast is shutdown? boot?


No Problem

nvidia driver 367.57
AMD FX™-6100 Six-Core Processor × 6
8GB Memory
Shutdown: about 3 sec
Boot Up: 6 secs

Same driver, ssd, 8GB ram, but intel i5.
So strange.
I am SO jealous of your reboot time

Have you had a look through dmesg

In Terminal type dmesg

It gives you a time stamp of the boot process, might give you a clue as to what is slowing your system down.

Or post the output here I will have a look for you.

Yes and thanks!

if i can recall snas? or something with “this took 23s!”
I’ve got it recorded at home.
something to do with IPv6

I’ll have to post the actual tonight.

Hey guys - I managed to find a solution a while ago by enabling nomodeset in the boot options. I’ve been told it’s not the best solution and should really only be enabled temporarily, but after enabling it permanently my install works just fine with nvidia drivers…so I’m satisfied with ‘it works’.

For reference, temporary nomodeset here: http://askubuntu.com/questions/38780/how-do-i-set-nomodeset-after-ive-already-installed-ubuntu

And permanent down the page here: https://ubuntuforums.org/showthread.php?t=1613132

I thought I’d share it because it sounds like other people are having the same issue? Hope it works.

I tried to post the whole dmesg but it is 3x bigger than the 32,000 char limit.

These 3 have the greatest wait times:
Diff Time Desc
24.7670628.116065 NMI watchdog: BUG: soft lockup - CPU#1 stuck for 23s! [nvidia-smi:506
8.626417 36.743297 IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
3.08765 40.444325 EXT4-fs (sdd1): mounted filesystem with ordered data mode. Opts: (null)

The 4th longest is 0.4 seconds.

Thanks for have a look!
(let me know if you know a way to post the whole dmesg)

I’ve had to use nomodeset when booting boot-repair or new installs.
But not with nvidia installed.

This made no difference for me.

Shutdown is 1:15 and boot is about 40s.

Oh sorry - I assumed if it worked for me it would solve it for anyone. I’ve got nothing else to offer though, being completely new to ubuntu.

Hope something works out…

I thought I had done this but I disabled Intel graphics in BIOS and now shutdown is 10s and so is boot.

Thanks all. RogueToad, you should check this. Maybe your boot can be even faster.

I’ll mark this Solved if I can figure out how.

thanks. I’m new to Mate as my main driver. Good to see this is a great community.:grinning:


or maybe you have to RogueToad (mark it solved)

Just did - and thanks, I’ll check your suggestion out. I would wonder why ubuntu needs this, but it’s done weirder things.