Nvidia issue - nvidia-settings

I have been running the alpha release on a couple of machines for several days now. So far, so good. Today I decided to see if I could configure dual monitors as separate X screens on one of my test machines. I had done this on 15.04 - so easy it was almost scary (I have had major problems with this in the past). I installed the nvidia driver using the “Additional Drivers” feature. The driver version I installed was nvidia 304.131 and the version of nvidia-settings is 352.21. These are EXACTLY the same as on Ubuntu Mate 15.04 on this machine.

When I invoked nvidia-settings it appeared that part of the program was “missing.” On my 15.04 OS I have a column on the left side of the program showing the following choices:

X Server Information
X Server Display Configuration (this is what I need to get to)
X Screen 0
X Screen 1
GPU 0 (GeForce 6200)
CRT-0- (XHD 15")
CRT-1- (Acer v193)
nvidia-settings Configuration

On the 16.04 OS I see only:

Application Profiles
nvidia-settings Configuration

As this is testing and I have nothing to loose I copied the xorg.conf file from the 15.04 OS to /etc/X11 on the 16.04 OS. I rebooted and nothing changed. I still have two monitors with the same image, not separate X Screens so it appears that xorg.conf is not read by 160.04. IS THAT TRUE?

I am at a loss. Can anyone clue me in?



p.s. I may hold my nose and install Ubuntu Unity 16.04 alpha and see what I can see.

p.p.s. I guess I should be referring to DAILY BUILD rather than alpha as I have learned that the official alpha is not due until 12/31. And I am not finding a daily build with Unity.


try starting here:


Hope it helps!. :smiley:

I'm not sure, but nvidia-settings could also write files to some other areas first which then triggers this file to be read. Having a /etc/X11/xorg.conf is deprecated I believe, I wouldn't be surprised if it's phased out entirely.

If I recall, I've seen this happen on a 14.04 or 15.04 machine before and it turns out the driver wasn't properly installed. Try re-installing it again, either switching back to Xorg from Additional Drivers, reboot, then reinstall. Or try the Ubuntu Drivers PPA which can install the latest NVIDIA drivers:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

At this time of writing, it's at 358.16.

Thanks Wolfman. That looks like a great reference. I will give it a read.

And thanks lah7. I did try reinstalling the driver - no change. I tried removing and installing nvidia-settings with apt-get. Still had the same.

I did see something in nvidia-settings about it saving some files but I did not look too closely. I will go back and check again. I was really looking for a way to setup the separate X screens and I saw nothing which seemed to relate to that. I have not setup Application Profiles with nvidia and I have no idea what they do - although I do not think they will help with what I am after.

I may just install the whole thing over again.


1 Like

Please post a bug at Launchpad for this, so the developers can also take a look at this.

Thanks wizd3m,

I did a complete reinstall of the OS (then a Clonezilla snapshot which I should have done before) then reinstaled the driver. Same thing. I restored the snapshot, added the ppa and installed nvidia-current. It brought down the same version of driver for my card. Same issue. i see that the drivers for 16.04 are under development so I WILL file a bug report once I get some more info. I need to try the 64 bit build - have to take down my “main” PC for that.

I will get to it in the next day or two.


I have filed the bug against the 340 package in the 32 bit OS. It is at https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/+bug/1529954 if anyone cares to have a look. I will be working on the 64 bit OS next. The card in my 64 bit machine uses Nvidia driver 352.63. I will report what I see here and create another bug report if necessary.


Dear wolfman , I have asus laptop 64 bit , it new with i7 intel chip … Some reason i put ubuntu mate disk in to install and erase win 10 , but error keeps poping up says ( unable to find a medium containing a live file system ) ??? went to bios turn fast boot off , what am i doing wrong ???