Panel not resizing, missing applets and a touchpad question

Is anyone else seeing an issue with resizing the top panel? As far as I can tell the top panel does not resize between 17 and 28 pixels as seen here:

The bottom panel can be visibly seen to contract from 28 to 17 pixels, something that can be checked for yourself or I can try to make another screen capture of the bottom panel. Does anyone have a fix for this behavior?

In addition to that I’m noticing two other things:

  • No volume control applet in the system tray, sound works and can be found in the System ->Preferences ->Hardware ->Sound option but no applet for easy administration.

EDIT: Sound applet came back when I reset the panel, this dropped me into the Familiar Layout for some reason instead of Traditional. After several attempts to induce that behavior again I’m acting on the assumption it was a result of the new Layout being added and a one time event unlikely to be experienced by anyone using a final release. I did want to mention it so you have a data point in case it happens to anyone else. Sound applet is there again and that’s great.

  • No shutdown button. (If this is intentional please disregard.)

EDIT: I see that the shutdown, logoff, and lock options are in the new applet that looks like a KDE icon. Is there any way to shove it on the far right side of the clock\calendar applet so it’s in the correct place? It just seems strange having it there instead of at the far right. I had thought maybe you were getting rid of it altogether and users were to shutdown from the system menu. Anyway to remove the new icon if it cannot be moved? I’d almost rather shutdown from the system menu if it can’t be moved.

  • Touchpad having extreme sensitivity (or seizures) from being touched. It’s almost like it’s dancing if I rest my finger on it even if I’m about to hit a button or highlight some text. Any idea what changed between Bionic and Xenial that would make this happen? Am I the only one experiencing this?

Video of the touchpad behavior:

Finally for the hardware issues, is there a log that can be submitted? Something to help the developers troubleshoot?

EDIT: Thanks to @elcste for explaining what was going on here:

As I noted in that thread, the new driver seems to already have a fix so it’s just a question of time before the issue goes away altogether.


Hi @bornagainpenguin,

I am running 18.04 Beta myself and don’t have the problems you have!. Try changing your software sources download location and updating again, it may solve your outstanding issues?:


I did the latest updates this morning, when I rebooted; my traditional panel wasn’t showing the shutdown/network buttons, I switched to “Contemporary” using Mate Tweak and then switched back to traditional which solved that problem (for now?). :smiley:

What about the top panel pixel reduction? Can it be resized to 20?

By the look of things no!, I have mine set at 34 which suits me though. :smiley: I think it starts at about 22?. :smiley:

It starts at 28 now and doesn’t reduce below that on the top panel. For comparison try reducing the bottom panel. It visibily and noticeably reduces all the way to 17. On the top panel the number of pixels reduces but nothing changes. I don’t know if it’s hard-coded icons or fonts but something is blocking it from working.

Hi @bornagainpenguin,

I think it is related to the screen resolution but I really don’t know?. I am happy with what I have now, on the current PC I have an AMD 2GB GPU, on another PC; one from Nvidia @ 1GB!. :smiley:

If it's the resolution there's not much I can do there. I've taken it to the highest this laptop can go, (which is where it already was) at 1366x768 and that didn't seem to fix anything for me.

I also tried setting the panel icon sizes but I'm really having a hard time seeing a difference there between the options. 16px looks the same to me as 22px and 24px. When I get to 32px, that's when things jump!

I noticed one other thing too--even though I set it to default for icon size, when I played the linked video to see if it recorded properly the vlc icon in the system tray was larger than the tray!

This is from my nvidia PC and set at 34:

Screen res set at 1920 x 1080:

On my AMD PC, the icons are huge at the same settings so I do think that it is to do with the res and/or the graphics card?. :smiley: