PC won't boot with Radeon HD 4850 attached

Motherboard: M4A88TD-V EVO/USB3
Video Card: ASUS EAH 4850
Monitor: ASUS S240HL & Phillips 200W
OS: Ubuntu Mate 20.04 (Dual Booting with W10)

Any suggestions regarding the following will be highly appreciated.
Last week the display froze and I believe the term is that I experienced screen tearing.

I’m no longer able to boot with the video card attached, but can still do so using the internal MB video so all is not lost. I read online about turning off the compositor in Marco which didn’t make any difference.

When trying to boot with the card I’m unable to access either BIOS or the recovery screen as the display goes directly to “Input Not Supported”. Also the monitor display control buttons fail to respond.

The hardware is ageing, I accept, and Mate 20.04 has perhaps highlighted issues never before encountered with prior Ubuntu versions such as printer connectivity, synology NAS connectivity, apps not working… Prior to 20 Ubuntu was always load and forget as it just worked – but as I say hardware is ageing.

On an old HDD I had Ubuntu 17 which did manage to to load a few times on the non-booting PC – then it failed to load a GUI environment. Am I correct in assuming that showed the video card is no longer serviceable from this and might need replacing? Not sure as it only I could still get to 'tty' environment after a couple of good boots. From Googling the issue I tried commands such as removing and reinstalling gnome-desktop. This failed to resolve the issue. Also tried to install lightdm – no improvement ( seemed to be a popular option).

I then installed Ubuntu Mate 18.04 onto the HDD, without any updates, by using the onboard video. No problems in booting to my graphical desktop. However, when I replaced the graphics card it boots to a black screen, without even being able to ‘CTRL ALT F’ to a tty screen - occasionally going into sleep mode.

Any suggestions before I replace the graphics card. The reason I use a card is that I run two monitors.

Sounds like a dead Radeon HD 4850 to me. ~12 years is not bad for a GPU.
And if you can't even display the bios screen when using it, it likely has nothing to with the OS.

1 Like

Many thanks for getting on this so quickly Utsuro, obviously not what I wanted to hear, but at least I know..... off to ebay now!

Bizarrely, I can probably confirm Utsuro's diagnosis... :slight_smile:

A while ago, I found an old 4870 while tidying up the office, which is a much more suitable card for my server than the 7950 that was in it. (Much lower power draw, even with the significantly better process node of the newer card). So I swapped the (very) old card in, and it all worked fine.
(I even ran some GL benchmarks on it, which were very amusing - for the ones that it could actually run at all! - compared to the Navi card the real machine is using these days).

So yeah - all the drivers for that generation are still there, and still work just fine. matebod's card almost certainly had indeed simply died of old age.

Hi, swapping out the old card worked, but before I did the old card started working again which was annoying - but binned anyway.