Pi 3 B + does not boot

I have downloaded an Ubuntu Mate system image ubuntu-mate-20.04.1-desktop-armhf+raspi.img.xz, have flashed it to a 32 GB SD card and tried to boot from that card for installing.!
I get the following messages, and the system stops:
Ubuntu Mate Boot Error 2020-12-09|690x387
This seems to be a fatal error based on some incompatibility.
Does someone know the reason ?

I had the same problem. I found no solution, but to flash an fresh 20.10 image - it booted well.

1 Like

Hi all,
I tried to set up my Raspi 3 Mod B with the freshly new Ubuntu Desktop 21.10 . image. The 32 bit image didn't even wanted to install. Error something cpu 0 not recognized. Tried with 64 bit image. That was INSANELY slow ! Stuck on something "configuring locales.." for at least 15 minutes, then something happen like black screen. I taught that it is time for restart because only the fan was spinning, rest was dead. Powering on, back to life but such a slooow life.. it takes centuries until desktop appears but then everything is unusable.: click on EVERYWHERE it reacts after 10 or more seconds still I could not open yet a terminal window.. As a mention, Raspberry OS is working normal on same hardware...

1 Like

I am having the same problem as @Kar0. My set up is Raspi 3B with Ubuntu Mate 22.04 image. The 32 bit image dind't install, after loading screen it got stuck in a black screen. When tried with 64 bit it was the same as @Kar0 too, stuck in "configuring locales..." for a lot of minutes (I wait 20 minutes until unplug it).

Update: With the 32 bit image, I changed the file config.txt and I set vc4-kms-v3d to vc4-fkms-v3d. Now the install wizard loaded. But still stucked in "configuring locales...".

1 Like

Welcome @dig0 to the community!

I encourage you to use the official image creator:

It has always worked fine for me.