Picamera install: Failed building wheel for picamera

Hi,
I'm stuck trying to install picamera
Env: ubuntu mate 20.04 32 bit, Pi 4

running pip3 install picamera gives error below.

I know at a hardware level the camera works. I tried the picamera-streaming-demo via snap, and it worked fine.

My ultimate goal is to ros development with the picamera.

Any help is appreciated!

[email protected]:/usr/lib$ pip3 install picamera
Collecting picamera
Using cached picamera-1.13.tar.gz (143 kB)
Building wheels for collected packages: picamera
Building wheel for picamera (setup.py) ... error
ERROR: Command errored out with exit status 1:
command: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-746xrms8/picamera/setup.py'"'"'; file='"'"'/tmp/pip-install-746xrms8/picamera/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(file);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, file, '"'"'exec'"'"'))' bdist_wheel -d /tmp/pip-wheel-9p8gs_qf
cwd: /tmp/pip-install-746xrms8/picamera/
Complete output (54 lines):
running bdist_wheel
running build
running build_py
creating build
creating build/lib
creating build/lib/picamera
copying picamera/bcm_host.py -> build/lib/picamera
copying picamera/camera.py -> build/lib/picamera
copying picamera/exc.py -> build/lib/picamera
copying picamera/init.py -> build/lib/picamera
copying picamera/frames.py -> build/lib/picamera
copying picamera/display.py -> build/lib/picamera
copying picamera/mmalobj.py -> build/lib/picamera
copying picamera/mmal.py -> build/lib/picamera
copying picamera/encoders.py -> build/lib/picamera
copying picamera/array.py -> build/lib/picamera
copying picamera/color.py -> build/lib/picamera
copying picamera/renderers.py -> build/lib/picamera
copying picamera/streams.py -> build/lib/picamera
running egg_info
writing picamera.egg-info/PKG-INFO
writing dependency_links to picamera.egg-info/dependency_links.txt
writing requirements to picamera.egg-info/requires.txt
writing top-level names to picamera.egg-info/top_level.txt
reading manifest file 'picamera.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
no previously-included directories found matching 'debian'
no previously-included directories found matching 'docs'
writing manifest file 'picamera.egg-info/SOURCES.txt'
installing to build/bdist.linux-armv7l/wheel
running install
Traceback (most recent call last):
File "", line 1, in
File "/tmp/pip-install-746xrms8/picamera/setup.py", line 145, in
main()
File "/tmp/pip-install-746xrms8/picamera/setup.py", line 119, in main
setup(
File "/usr/lib/python3/dist-packages/setuptools/init.py", line 144, in setup
return distutils.core.setup(**attrs)
File "/usr/lib/python3.8/distutils/core.py", line 148, in setup
dist.run_commands()
File "/usr/lib/python3.8/distutils/dist.py", line 966, in run_commands
self.run_command(cmd)
File "/usr/lib/python3.8/distutils/dist.py", line 985, in run_command
cmd_obj.run()
File "/usr/lib/python3/dist-packages/wheel/bdist_wheel.py", line 259, in run
self.run_command('install')
File "/usr/lib/python3.8/distutils/cmd.py", line 313, in run_command
self.distribution.run_command(command)
File "/usr/lib/python3.8/distutils/dist.py", line 985, in run_command
cmd_obj.run()
File "/tmp/pip-install-746xrms8/picamera/setup.py", line 109, in run
raise ValueError('This system does not appear to be a Raspberry Pi')
ValueError: This system does not appear to be a Raspberry Pi


ERROR: Failed building wheel for picamera