Play Bluray in VLC

Hi Jose,

did you follow the advice above (I cannot find it @ouroumov?) and do you have the following packages installed?:

sudo apt-get install libaacs0 libbluray-bdj libbluray1

libdvdcss2 can be downloaded from here if you cannot find it in the Software Boutique:

64 Bit:

32 Bit:

Hello Wolfman, all packages are already installed.


What I am reading from the above is that the file simply cannot be read!, right click the file(s) you are trying to play and display their properties please so we can determine whether or not the files are corrupted!. :smiley:

the second disc also

/usr/bin/mpv --no-config --no-quiet --terminal --no-msg-color --input-file=/dev/stdin --no-fs --hwdec=no --sub-auto=fuzzy --vo=xv, --ao=pulse --no-input-default-bindings --input-x11-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=41943059 --monitorpixelaspect=1 --osd-scale=1 --sub-ass --embeddedfonts --ass-line-spacing=0 --sub-scale=1 --sub-text-font=Arial --sub-text-color=#ffffff --sub-text-shadow-color=#000000 --sub-text-border-color=#000000 --sub-text-border-size=2.5 --sub-text-shadow-offset=5 --sub-codepage=utf8:ISO-8859-1 --sub-pos=100 --volume=55 --cache=2048 --osd-level=0 --screenshot-directory=/home/jose/Imágenes/smplayer_screenshots --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --audio-channels=2 --af-add=scaletempo --af-add=equalizer=0:0:0:0:0:0:0:0:0:0 --softvol=yes --softvol-max=110 --ytdl=no --term-playing-msg=MPV_VERSION=${=mpv-version:}
–term-status-msg=STATUS: ${=time-pos} / ${=duration:${=length:0}} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} /media/jose/ATTACK_OF_THE_CLONES/BDMV/PLAYLIST/00011.mpls

Playing: /media/jose/ATTACK_OF_THE_CLONES/BDMV/PLAYLIST/00011.mpls
Failed to recognize file format.
Exiting… (Errors when loading file)

is original, MakeMKV works and what makes matroska,

with XP can see the Movies.

VLC and smplayer can not see.


Hi @Josele13,

I’m not sure why it won’t play as you say that everything you need is installed so now do the following:

  1. Change your software sources download location to a different download server (see update guide* on how to do this if you don’t know!).

  2. Once you have done the above, run the following terminal command (Ctrl + Alt + t):

sudo apt-get remove vlc && sudo apt-get update && sudo apt-get dist-upgrade -f && sudo apt-get install vlc

  1. Try playing you disks again and see if that helps!. :thumbsup:

If anyone else on the forum has an idea, please post your thoughts as I am stumped!. :smiley:

Hi Wofman , I changed the server by another of France, I have performed the operation in terminal, as is still the same, may be some configuration set of ACCS,

do not worry, I will install VirtualBox with XP,

Thanks for helping me, you're the best ...

Hi Jose,

did you follow this advice when creating your bootable media as VLC should run no problem?:

Have you tried playing different DVD’s and not just the Star Wars set?. :slight_smile: D

That is actually for playing encrypted DVDs only - Blu-rays use a different set of copy protection (AACS and BD+) instead of the old Content Scrambling System employed for DVDs.

1 Like

This (and the screenshot above from SMPlayer) simply indicate the Blu-ray disc is being opened as a DVD (likely because of missing Blu-rays support) - which of course does not work. The whole /VIDEO_TS folder simply does not exist on Blu-rays at all - they use a different folder/file structure than DVDs.

The how-to linked in the second post is actually the best I found on this topic so far, yet the key takeaway mentioned there is “How to Play (Some) Blu-rays on Linux with VLC”.
The linked key database does not seem to contain the ones needed to play those particular discs. Trying others which are listed there might work but it’s definitely very hit-and-miss on Linux.


Question, any configuration may be reading unit in UM or the BIOS?


Hi Jose,

I’m not quite sure what you mean by your last reply?.

I do have a question for you, are you 100% certain that your DVD drive on your PC is indeed “Blueray capable” ?.

If it did not, it couldn’t even physically read the disc, let alone mount it, but some of the messages above clearly show it was mounted.
The laser used for reading DVDs isn’t able to read Blu-rays.

hi @maximuscore,

I thought BlueRay disks could do both normal DVD playback and BlueRay which is why I asked if his DVD drive is indeed a BR capable drive?. :confused:

The competing (but long dead) HD-DVD format had a combo-variant where you had a DVD layer and a HD-DVD layer on the same disc, like SACDs also have a backwards-compatible CD layer, but for Blu-rays something like that was never used, as far as I know.

Thus there are no commercial Blu-ray discs that can also be read by a plain DVD drive.

The only thing that comes kindof close are “Mini-Blu-rays”, i.e. the filesystem and data structure of a Blu-ray burned onto a regular DVD. These are mostly useful for homemade video, due to space constraints, and not all Blu-ray players support them.

1 Like

Wolfman and Maximuscore hello, thanks for your help, with MakeMKV bluray reader works and the film makes me Mkv, then it works, VLC begins to read but can not find where it starts, the CPU is at 100%. With SMPlayer you know what gets me, will not start

Hi @Josele13,

do you have the following package installed?:

sudo apt-get update && sudo apt-get install libavcodec-extra libavcodec-ffmpeg-extra56 mencoder


The original commands given were wrong and have been replaced with an updated command for anyone else reading this thread!. :thumbsup:

Hi Wolfman, I think I have not installed, then I try to see if it works. Thank you

1 Like

Hi Jose,

this might interest you (use at your own risk!):

there is no package libavcodec extra-53

jose @ jose-GA-MA78LMT-US2H: ~ $ sudo apt-get install libavcodec-extra-53
[Sudo] password for jose:
Reading package lists ... Done
Building dependency tree
Reading state information ... Done
The libavcodec-extra-53 package is not available, but some other package references
to it. This may mean that the package is missing, outdated or just
available from any other source

E: The package "libavcodec-extra-53 'has no installation candidate
jose @ jose-GA-MA78LMT-US2H: ~ $