Please help can't get my newly installed fonts to work!

Hi there
noob here.
installed gillius font of the arkandis digital foundry on my machine

here is the place i “think” it put it

usr/share/fonts/truetype/adf/GilliusADF-Regular.otf: Gillius


and I want to use it in my python program. I “installed” it and my software center says it’s there BUT I can’t see it anywhere?? What am I missing here please?

here is an example message from my python program

Warning (from warnings module):
“/usr/lib/python3/dist-packages/matplotlib/”, line 1279

(prop.get_family(), self.defaultFamily[fontext]))
UserWarning: findfont: Font
family [‘GillSans’] not found. Falling back to Bitstream Vera

Warning (from warnings module):
“/usr/lib/python3/dist-packages/matplotlib/”, line 1289

UserWarning: findfont: Could not match :family=Bitstream Vera
Returning /usr/share/matplotlib/mpl-data/fonts/ttf/cmmi10.ttf


see the following for more info on manually installing fonts:

Hi Wolfman

thank you for the reply BUT I “think” I already installed the fonts via the software center. The issue is that I don’t know how to test it out as I can’t see the font in a python program I have written that uses MATPLOTLIB. How can I test if a font is installed please?

thank you again

Paste the following command in a terminal and it will show you a complete list of installed fonts:


hey Wolfman
thanks again BUT :slight_smile: I did that, I swear have tried everything!!! The issue is that I can’t seem to use it in my python program. I will ask the question over in the stackoverflow as I am convinced I have installed this correctly. I might just give in and go back to windoze :frowning: thank you for trying though.

The font is in ( sorry I am cutting an pasting from a poorly formatted file ).

/usr/share/fonts/truetype/adf/GilliusADFNo2Cd-Italic.otf: Gillius ADF No2 Cd
usr/share/fonts/truetype/adf/GilliusADFNo2-BoldItalic.otf: Gillius ADF No2:style=Bold Italic

I am not an expert on python (or anything else for that matter!) so maybe you should make sure that all the bits & pieces of python are indeed installed?.

Try installing the package “python-fontforge” via the terminal:

sudo apt-get install python-fontforge

Font editor - Python bindings

Besides being a font editor, FontForge is also a font format
converter, and can convert among PostScript (ASCII & binary Type 1,
some Type 3s, some Type 0s), TrueType, and OpenType (Type2),
CID-keyed, SVG, CFF and multiple-master fonts.

This package provides the Python modules (the libraries fontforge and
psMat) to access a FontForge program for font manipulations.

1 Like

thank you wolfman
I didn’t know python-fontforge existed. As to you not been an expert on anything, I disagree. You are an expert in helping people and that is something to be proud of. Thank you for taking the time to help a noob

1 Like

Hi theakson,

has it solved the problem?. :smiley:

Hey wolfman
don’t know yet as I am away from the machine where the code is located. It is an excellent response though and worth pursuing. Incidentally I don’t really see where to flag the question answered, you got any ideas OR do I just update the subject line. Thanks again for your help and being a great guy

just update the subject line!.

I did put in a request for a "SOLVED" button but it ain't happened yet!. :smiley:

And you are welcome btw!. :smiley:

will do and THANK you