Please me help me make my 5.1 suround sound work

Hi, I’ve been using Ubuntu-Mate as a base for my television computer running the media center formerly known as XBMC for some time now. In the past I ran my sound directly out the onboard sound card which being very basic only offered stereo sound. Recently due to some changes I was able to get my sound card back from my spare box currently powering my Dad’s television.

Now I was able to get stereo 2.1 sound while in Ubuntu-Mate 14.04.2 after I edited the pulse daemon.conf file as required to get pulse to see it. Unfortunately pulse audio still insisted on not seeing the card as anything more powerful than 2.1 despite all the editing I did and the various attempts at using alsamixer or reinstalling the alsa packages. Nothing seems to have worked.

In frustration I gave up and went to Windows 7 as an effort to ensure the card actually worked and wasn’t malfunctioning. In Win7 everything works but the system is a dog with that much code running all the time and various configuration issues with Kodi (the media center formerly known as XBMC) are driving me up a wall. I want my Ubuntu-Mate back!

Can anyone please help me get the full 5.1 sound working in linux?

The card is this one here.

Thanks for all help provided.

EDIT: Have blown away my Windows 7 install in anticipation of getting this to work, am now running Ubuntu-Mate 14.04.2 with all updates and Kodi is installed and ready to start blasting 5.1 sound.

EDIT II: Here’s the output of some commands which might give useful information:

lscpi

04:09.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)

lsmod:

Module Size Used by bnep 18895 2 rfcomm 53664 4 bluetooth 342208 10 bnep,rfcomm nvidia 10333941 30 snd_ice1724 125988 2 snd_ak4113 14348 1 snd_ice1724 snd_pt2258 12955 1 snd_ice1724 snd_ak4114 14296 1 snd_ice1724 snd_ice17xx_ak4xxx 13163 1 snd_ice1724 ir_lirc_codec 12869 0 snd_ak4xxx_adda 18303 2 snd_ice1724,snd_ice17xx_ak4xxx ir_rc6_decoder 12754 0 ir_jvc_decoder 12655 0 ir_sanyo_decoder 12727 0 ir_sony_decoder 12625 0 ir_rc5_decoder 12622 0 ir_nec_decoder 12787 0 ir_mce_kbd_decoder 13030 0 lirc_dev 19324 1 ir_lirc_codec snd_i2c 13827 2 snd_pt2258,snd_ice1724 snd_ac97_codec 105709 1 snd_ice1724 rc_rc6_mce 12454 0 ac97_bus 12642 1 snd_ac97_codec snd_pcm 85501 4 snd_ice1724,snd_ac97_codec,snd_ak4113,snd_ak4114 mceusb 21676 0 snd_page_alloc 14230 1 snd_pcm rc_core 26724 12 lirc_dev,ir_lirc_codec,ir_rc5_decoder,ir_nec_decoder,ir_sony_decoder,mceusb,ir_mce_kbd_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_sanyo_decoder,rc_rc6_mce snd_seq_midi 13132 0 snd_seq_midi_event 14475 1 snd_seq_midi snd_rawmidi 25135 2 snd_ice1724,snd_seq_midi joydev 17101 0 snd_seq 55383 2 snd_seq_midi_event,snd_seq_midi snd_seq_device 14137 3 snd_seq,snd_rawmidi,snd_seq_midi snd_timer 28584 2 snd_pcm,snd_seq snd 60939 17 snd_pt2258,snd_ice1724,snd_ac97_codec,snd_timer,snd_i2c,snd_pcm,snd_seq,snd_rawmidi,snd_ak4xxx_adda,snd_seq_device,snd_ak4113,snd_ak4114,snd_seq_midi soundcore 12600 1 snd kvm_amd 50568 0 kvm 388310 1 kvm_amd dcdbas 14448 0 serio_raw 13230 0 nv_tco 13300 0 drm 244037 1 nvidia k8temp 12842 0 i2c_nforce2 13037 0 shpchp 32128 0 mac_hid 13037 0 parport_pc 31981 1 ppdev 17391 0 lp 13299 0 parport 40836 3 lp,ppdev,parport_pc hid_logitech_dj 18165 0 usbhid 47070 0 hid 87604 3 usbhid,hid_logitech_dj usb_storage 48417 1 tg3 152160 0 pata_acpi 12886 0 ptp 18445 1 tg3 pps_core 18799 1 ptp sata_nv 23004 3

lshw:

*-multimedia description: Multimedia audio controller product: VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller vendor: VIA Technologies Inc. physical id: 9 bus info: [email protected]:04:09.0 version: 01 width: 32 bits clock: 33MHz capabilities: pm bus_master cap_list configuration: driver=snd_ice1724 latency=64 resources: irq:17 ioport:9c00(size=32) ioport:9800(size=128)

aplay -l

**** List of PLAYBACK Hardware Devices **** card 0: ICE1724 [ICEnsemble ICE1724], device 0: ICE1724 [ICE1724] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: ICE1724 [ICEnsemble ICE1724], device 1: ICE1724 IEC958 [ICE1724 IEC958] Subdevices: 1/1 Subdevice #0: subdevice #0

dpkg -l | grep “alsa”

[code]ii alsa-base 1.0.25+dfsg-0ubuntu4 all ALSA driver configuration files
ii alsa-utils 1.0.27.2-1ubuntu2 i386 Utilities for configuring and using ALSA
ii bluez-alsa:i386 4.101-0ubuntu13.1 i386 Bluetooth ALSA support
ii gstreamer0.10-alsa:i386 0.10.36-1.1ubuntu2 i386 GStreamer plugin for ALSA
ii gstreamer1.0-alsa:i386 1.2.4-1~ubuntu1 i386 GStreamer plugin for ALSA
ii libsox-fmt-alsa:i386 14.4.1-3ubuntu1 i386 SoX alsa format I/O library

[/code]

See last post for what I ended up doing that worked for me.

Hi,

install the package "paman" which is the frontend for Pulse Audio and use the Pulse Audio Manager to control your device:

sudo apt-get install paman libsox-fmt-all sox

You will find it once installed under. Applications > Sound & Video > PulseAudio Volume Control

http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/PerfectSetup/

https://wiki.ubuntu.com/PulseAudio

Check the various tabs at the top and maybe you can solve your problem that way:

This is what I get in paman. There are no profiles for suround sound. Just stereo.

I should add that since this is a fresh install* so I have not edited the daemon.conf file I mentioned above because I wantred to give the people helping me as stock an install as possible. I am only changing what I am being told to do in this thread.

  • excepting all updates, Kodi, IR for the MCE remote and enabling of the nvidia video driver which is vga onboard only so no interference in that department because there are no HDMI or DVI ports. I haven't even installed Pale Moon Browser yet!

Hi,

do you have your software sources download location set to “Main”?, check out the update guide and change the settings per the guide and then try updating again.

Do you have codecs installed?.

sudo apt-get install ubuntu-restricted-extras libxine2-all-plugins faac flac gstreamer0.10-plugins-ugly gxine libdvdread4 totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 mpg321 libavcodec-extra

I do not have my software sources set to 'main" as one of the first things I do after a fresh install is tell the system to search for the best mirror in my area. I do it without even thinking these days, it's so automatic. Makes a huge difference in downloading of updates too!

Are you suggesting that this may be causing me to not have my sound card configured correctly? Can't really see how that would be.

I did install the codecs you mentioned. Since I use Kodi, the media center formerly known as XBMC for all my media playing needs on this computer I'm not sure how needed they were but better safe than sorry because I missed something so simple, right?

Still showing as only stereo in paman. Reminder that I have not edited the daemon.conf file this time around as of yet.

PS: I went back and edited the first post to give output commands of various information about the hardware, in case it helps.

What devices are showing in the configuration window of Paman?:

Do you have the speakers connected to the correct socket in the soundcard?, it should be plugged into the light green socket!. (I know that you know that but I have to ask!).

Your soundcard is set to "Set as fallback" in "Output devices?:

All your printouts indicate that the card is working so it can only be a switch somewhere; or the wrong socket!.

Also, check the Hardware settings in your normal sound preferences and look at what (if any) devices are listed, you may have an internal card set as "Active"?:

The pictures above that I've posted are actrual screenshots of my system. Nothing has changed in them since we began.

I'm pretty sure everything is plugged in properly. Yellow to yellow, black to black and green to green. The top one is hard to tell from the picture but it's labeled line in and is actually blue not green.

The default sound menu only lists the card as stereo duplex, despite being quite capable of surround sound in Windows 7.

Have you tried any of the other settings shown in your 2nd pic?, I would start with the 3 other output settings and don’t worry about “Duplex” for the moment!.

Trying the other settings results in no sound whatsoever. Nothing seems to be muted that I can tell in alsamixer when I switch over to the other outputs but I definitely lack audio. Will try to check this again when I return home from work but that was the experience I had previously.

EDIT: Just checked it and despite pulseaudio showing something on the meter while attempting to test speakers (which again only show as stereo) there was no audio output in the other settings. Screenshot of alsamixer to prove that nothing is muted.

Do I at some point edit the daemon.conf file or is that supposed to no longer be necessary? I ask because most of the guides I've found for my card are at least five years old now and mostly seem to refer to some onboard shuttlepc motherboard whereas my card is still fairly new and is separate from a motherboard.

Hi,

somewhere there is a switch which is preventing it from working!.

Take a look here but remember what you do!:

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

Also,

do you have a double ended plug system on your speaker cables and are they sitting correctly at both ends?, I ask because I have such a speaker set!. :smiley:

You can also (making sure your software sources are set to Main), run the following command and do a restart:

sudo apt-get update && sudo apt-get install -f

Okay, running through it now…

Here’s the alsa-info.sh output:

http://www.alsa-project.org/db/?f=9f5fa771ace065e1bccc8ee16974ccac5b42b2c3

Will update t his post as I continue working my way through the lists…

Finished reading the rest. Mostly seems to be duplication of the logs I have already posted above, plus a request to make a thread on Launchpad, somethng I am not very eager to do given the constant wontfix and expired bugs (which aren’t fixed) I constanatly see on that site.

Another thought, are you running your sound through an external system like a sub woofer/amp or something?.

These are my speakers:

http://www.logitech.com/en-us/product/surround-sound-speaker-z506

Just checked and everything is plugged in firmly. Not sure what you mean by through an external system.

What I meant was; are you using an elaborate external sound system but I see you aren’t.

Okay, clutching at straws, is your soundcard set to “Headphones” only?, do you have an onboard soundcard and is it switched off in BIOS?. .D

Also, please paste the following command in a terminal and paste the results here please, you will end up with something like mine:

aplay -l

Have you tested whether you get sound just through headphones or not?.

You can also try running the following command which I took of of this website (see below):

sudo alsa force-reload

RESTART YOUR PC AFTER RUNNING THE ABOVE COMMAND!.

[quote=“wolfman, post:15, topic:747, full:true”]Okay, clutching at straws, is your soundcard set to “Headphones” only?, do you have an onboard soundcard and is it switched off in BIOS?. .D
[/quote]

I don’t believe the soundcard is in headphones only because I get sound just fine in the duplex mode–just in stereo only and not even the profiles for any surround sound options.

I do have an onboard audio, some intel thing, really basic which I have disabled in the bios, do you recommend turning it back on?

Please see the first post, I have that information in there towards the bottom.

EDIT: Was talking to a friend at work and it hot me that we may have a miscommunication here–I have sound–it’s just stereo only and I want the full surround sound I know my hardware is capable of. There is sound coming out of my speakers, just not all of them when I test the playback using the speaker-test command (speaker-test -c 6) has only ever given me 2.1 sound at best.

I’m not so foolish to think everything can use all the speakers–it must be made for 5.1 sound, I know this–but I want there to be configuration options in the volume control which seem to be missing and I want to hear all the speakers working on films which have the full 5.1 soundtrack in them and in tests which are supposed to playback in all speakers one at a time.

I apologize if there wasn’t any misunderstanding but it seemed to me the last few posts were assuming that I had no audio at all. I do have stereo, I just want the full 5.1 sound my card is capable of. Thank you again for the time and energy you’re expending here trying to help me with this. I appreciate your patience troubleshooting this between my work hours and sleep.

No, leave it off!.

you do have surround active in Alsamixer so maybe fiddle around there a little more?:

Sorry to say that apart from that, I am all out of ideas, I cannot tell you anything more as I only have a basic speaker setup and can only refer you to more pages:

https://help.ubuntu.com/community/SurroundSound

Again I appreciate your having taken the time to try and help.

I went ahead and made the changes to daemon.conf suggested here:

http://www.webupd8.org/2009/06/enable-surround-sound-in-ubuntu-linux.html

I also added the tweaks suggested by Paweł Tomaszewski except the change in default sample rate since that seems to produce an error when it is the same as some internal default. I rebooted and still had stereo (but that was expected) then resumed googling about my sound card and Linux\Ubuntu researching all over the place.

I started to have a suspicion that I needed to pass on a module or something to get the card properly detected after reading about how the snd_ice1724 module works with various models. I tried editing the alsa-base.conf file:

/etc/modprobe.d/alsa-base.conf

I added the “options snd-ice1724 model=SN25P” option and rebooted and suddenly I had profiles listed in both the mate volume controller and in the paman volume controller! The problem is none of them seem to have any sound output except through LFE (woofer I think?) so I commented out the line and rebooted getting stereo duplex again and sound but no profiles.

I’m now trying the various models available but I have no idea which one is equivalent to “VIA - Tremor VT1723” which is what the card specifically says to be on the retailer whose site I bought from and which model matches the box of the sound card listed. An y advice in narrowing this down would be appreciated!