Plex Media Server and Mate 18.04 LTS, can they work together?

Is anyone successfully running Plex Media server on 18.04 and retrieving video data?

I am running a Plex Media Server using Ubuntu MATE 18.04.3 via a snap without issues.

sudo snap install plexmediaserver

I am running Plex on an 18.04.3 MATE server and since setting it up, have had no problems using it. I use Basilisk instead of Firefox for looking at movies in the evening. At the moment I am running Version 3.108.2 with no access outside my LAN. What seems to be your problem xaire?

I use Firefox as the browser to watch movies. I also use Kodi with the Plex add-on on several devices as well.

Morning Michael,

My main problem is trying to use external drives [USB] [x 2, 3TB & 4TB, formatted ntfs]. Plex reports the disks but does not recognise any content. [Plex reports "There are no items in this folder" - used paths /media/ray/Biggy4 (movies) and /media/ray/Biggy2 (TV Shows) in setup.

According to a Plex help file [] Plex cannot see files on Linux and gives a procedure to change Linux to 'see'. I tried it and failed - had to reload Clonezilla image from before my try to get 18.04.2 to restart.

Am using 18.04.3 but will do a fresh reload to abandon all my failed Plex tries and the link to my tablet [Amazon Fire HD10 - black Friday special last year running the Plex app version with which I can access the Plex media server via my WiFi ]

Any advise/help/ hope will gratefully accepted. Been trying Plex server for a long while.

franksmcb has suggested snap to load? [sudo snap install plexmediaserver]

Ray Pitts [xaire]

Ray, I've been busy with other stuff but will have something for you within a couple of days. Thanks for your patience.

To Michael,

Your experience with Plex brings me renewed hope. Will get a fresh 18.04.3 up to speed so long.

Ray Pitts

Ray, franksmcb's suggestion to use snap to load is great. It will update whenever possible and save you the trouble of going through my updating procedure below. If I were doing this again, I'd be using a snap.

NOTE: Deleting movies in plex also deletes the original .mkv or .m4v file. I did not want to expose my movie collection to plex directly, so I initially created a curated set of movies on longitude /data3. I used caja to copy movies from the WD USB drive to the appropriate dvd_rips file on /data3. There is a setting somewhere in Plex to avoid deleting your files; uncheck "Allow media deletion" in Settings, Library, show advanced.

Sept. 29 - This morning Plex reported that an update was available. I chose to download the update, however the update package was downloaded to my client rather than to my server. I copied the package to my server /Downloads directory using SFTP. I use SSH to connect to all my servers and changed to the /Downloads directory and issued the following command:

$ sudo dpkg -i plexmediaserver_1.17.0.1709-982421575_amd64.deb 
[sudo] password for michael: 
(Reading database ... 252193 files and directories currently installed.)
Preparing to unpack plexmediaserver_1.17.0.1709-982421575_amd64.deb ...
Removed /etc/systemd/system/
Unpacking plexmediaserver ( over ( ...
Setting up plexmediaserver ( ...
Created symlink /etc/systemd/system/ → /lib/systemd/system/plexmediaserver.service.
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for ureadahead (0.100.0-21) ...
ureadahead will be reprofiled on next reboot

But before you reboot your server to finish installing Plex, I suggest that you should create a new mount point and make sure that it belongs to you. Create /home/external using sudo pkexec caja and set yourself as owner.

Also you should edit the server's fstab file found in /etc/fstab using sudo pkexec pluma /etc/fstab.

The following fstab file is shown as an example. /home/external is shown as the new directory for one of your USB drives. You can create /home/external1 and /home/external2 later on if you are successful.

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system>                         <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=(garbled UUID numbers)             /               ext4    errors=remount-ro 0       1
# /home/data2 was on /dev/sda2 during installation
UUID=(garbled UUID numbers)             /home/data2     ext4    defaults          0       2
# /home/data3 was on /dev/sdb2 during installation
UUID=(garbled UUID numbers)             /home/data3     ext4    defaults          0       2
# added on July 29, 2019 to mount WD USB drive
UUID=(UUID number of your USB drive)    /home/external  ntfs    defaults          0       0
# swap was on /dev/sda3 during installation
UUID=(garbled UUID numbers)             none            swap    sw                0       0

mount USB drive UUID=?? /home/external ntfs defaults 0 0

You can find your UUID number by using either Gparted and selecting information on the desired drive or by opening Disks on the server.

After doing the above, issue $ sudo reboot now

When your server comes back up you should be able to see files (and more importantly directories to add) from Plex.

Edit: Ray, if there are any questions or places where I've been unclear, please don't hesitate to ask or note my haziness.

1 Like

Morning Michael,

Thank you for your time and the directions you have given.

These instructions are right at the ragged edge of my present linux knowledge so it will take me a week or two to read background and gain confidence where a step is at present beyond me technical understanding.

Some areas eg, systemd I will simply perform blindly as this and associated systems are beyond my understanding.

Thank you for the challenge. I am working on it.

Raymond Pitts

Ray, I included the stuff that occurred after I did the sudo dpkg -i plexmediaserver_1.17.0.1709-982421575_amd64.deb command for your benefit. No need to study systemd or any of the things that happened after using dpkg to install the server. Maybe just use franksmcb's suggestion to install Plex using a snap - sudo snap install plexmediaserver.

Then create mount points for mounting your USB drives.

Then edit fstab to mount the USB drives using their UUIDs.

Then reboot and see if everything worked out as expected. Any questions, please post them here Ray.

1 Like

On it. Thanks.

Raymond Pitts

For Michael.

Some questions.

In terminal the DF command lists all disks turned on at that time. [internal & external]

In /etc/fstab I only have the startup disk [/&swap] for security and physical-disk-conservation [mechanical].

Startup disk is 240gb SSD.

My external drives [x3] are all over 3tb, ntfs and mechanical.

Is there somewhere [except /etc/fstab] I can define the mount point for individual drives? [or does this defeat Linux universality]

For everything [?except startup & swap] mine uses /media/ray/...? as the mount point - which Plex cannot see.

If I put my video media externals in /etc/fstab but do NOT power them up at startup and only power up when needed, will it use the mount point defined in /etc/fstab?

Before modifying /etc/fstab [and experimenting] - to minimise reloading Clonezilla images - I'd like to clarify this last question/proposal.

Ray Pitts

No. Not as far as I know.

If you try to do that, you will not be able to boot. Linux looks for all drives called out in fstab as it boots. So the technical answer to your question is yes. It will use the mount defined in fstab.

Edit: Your new entries for each USB drive (given that you will be mounting 3 such drives) in fstab should look something like this:

# added the following as a mountpoint for USB drive1 so that plex can see it
UUID=F474BCAA64B76DCC /home/external1 ntfs defaults 0 0

Good luck Ray.

1 Like

Thanks for the help, it will be well used.

For Michael

This is a general /etc/fstab problem which can [I think] be answered by anyone but me.

[.odt file as attachment]

Raymond Pitts

(Attachment Comm01.odt is missing)

What's your problem?

For Michael

‘Good luck’ seems to be 90% plain, time consuming trial and error and much reloading.

My 3tb External [Biggy2] worked first time with the settings as per your WD. [Plex worked and saw and used the drive – much understanding and tweaking of Plex still pending]

The 4tb external has consumed 5 days [I’m a pensioner] of trying by itself [I’ve removed all trace of the 3tb drive while getting the 4tb working]

4tb is a Seagate Barracuda 4TB ST4000DM004 SN ZFOWDHP PN 2CV104-300 FW 0001 WWN 5000C500A5EOB668 PSID

It is loaded in an external case ENIYOU USB 3.0 HI-SPEED

The 3tb case is an ASTRUM, also USB 3.

When Biggy4 is mounted by the normal system in / dev as [See SS01 below] sdf1 it mounts normally but in /home/external1 or home/external2 using /etc/ fstab it fails.

Biggy2 works and Plex can use it in either /home directory.

Using both, separately, the UUID and PARTUUID and the other items in your WD USB example [UUID /home external ntfs defaults 0 0] only PARTUUID tried to start [but failed].] UUID DID NOT EVEN TRY TO START.

The /home directories for mounting the externals are: [see SS02]

The unused /home directories are empty [See SS03]

Can you advise why the Biggy4 drive won’t mount? (ntfs format and partitioning was already done when I bought the unit/external drive as a unit. It worked ‘out-the-box’ mounting in /dev.

My other 3TB drive [the one that works] I recently repartitioned and formatted ntfs with Disks but earlier it also worked ‘0ut-of-the box’.

Just intuition. [Will Disks partition a 4TB drive?]

Biggy 4 fails here as shown above:

The dirs for mounting externals are above:

The unused /home/external1 and 2 directory above are empty:

So your unsuccessful fstab looked like this:

# Ray's fstab that didn't work to mount Biggy4
UUID=0D3BF61829128A7C /home/external2 ntfs defaults 0 0

# Ray's fstab that did work to mount Biggy2
UUID=UNKNOWN-PART-UUID /home/external1 ntfs defaults 0 0

It looks as if you have 4 USB drives that presently mount in /media/ray, Fast, Linux2, Linux1 and Biggy4

The next fstab to use for Biggy 4 might be something like this:

# Ray's attempt to mount a recalcitrant Biggy4 USB drive
/dev/sdf1 /home/external1 ntfs defaults 0 0

or maybe even

/dev/sdf1 /home/external1 ntfs defaults,nofail,x-systemd.device-timeout=30 0 0

I got this one from the next to last answer at -

IMPORTANT - I didn't test this but looks good.

The disadvantage is using dev's identity of Biggy4 as "sdf1", UUID is a much more particular means of identity and I guess that much more difficult for you for some unknown reason.

Food for further thought:

Searching on "use fstab to mount usb drives" got me these -

See the community help page - a comprehensive explanation how USB drives are automatically mounted in /media a thread that shows a user such as yourself trying to use fstab to mount his USB drive, it doesn't work but is present in every dratted fstab search.

Searching on "ubuntu: can USB drive be mounted in fstab to appear as local drive" I got: Uses Exfat as their example, drives IDed by /dev, seems to be tailored to plex. looks OK. Drives IDed by /dev

One other thing. I may have been wrong to advise you to make the mountpoints be yours. I just noticed that my mountpoint is (and was) owned by root. Having external1 and external2 be owned by ray could slow down their mounting. In any case NTFS has no ownership so the mountpoints don't have to be owned by the user.

Thank you for both prompt replies. There is much new experimenting ahead for me with fstab.

I have created a switch box to power all my external drives individually leaving all the USB's permanently connected. To eliminate a possible influence of my switch box on Biggy4 mounting with fstab I powered it with a stand-alone transformer which changed the Biggy4 /dev name to sdf1.

Your first 'food for thought' hint holds ideal potential.

Will let you know when I find a solution or hit a blank wall.

Raymond Pitts