Power-manager crashes in Ubuntu Mate 16.04 LTS

This happens often in my pc, i tried to reinstall the package or install alternatives ones but the problems persists.

Any suggestions?

Hi @Ritman,

try running a full system update if you haven't already done so :thumbsup:

i was unable to update because it shows me an error with some programs ppa (google earth and QGis), i disable this ppa in “Softwares and Updates” and now it works!

1 Like

i have restarted my computer again and the problem persist

Try changing your software sources download location first (per the update guide) and then run the following terminal command:

sudo apt-get update && sudo apt-get remove mate-power-manager && sudo apt-get install mate-power-manager

after reinstall, the problem's gone for a while (for 2 or 3 boots) then appears again.

That crash report is being generated by apport.


It is possible thats its a false positive and apport just needs to be reset. So in terminal…

sudo rm /var/crash/*

i don’t think that is a false positive, because when it happens i cant see my battery status and i cant change the brightness.

Maybe after suspend?

Could you post your specs? In terminal..

inxi -b

i almost never suspend my pc

System: Host: Felsico Kernel: 4.4.0-22-generic x86_64 (64 bit) Desktop: MATE 1.12.1
Distro: Ubuntu 16.04 xenial
Machine: System: Acer (portable) product: Aspire V3-371 v: V1.29
Mobo: Acer model: Aspire V3-371 v: V1.29 Bios: Insyde v: V1.29 date: 09/03/2015
CPU: Dual core Intel Core i5-4210U (-HT-MCP-) speed/max: 888/2700 MHz
Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller
Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 11.2.0
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
Card-2: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k
Drives: HDD Total Size: 240.1GB (12.9% used)
Info: Processes: 190 Uptime: 25 min Memory: 1164.4/3874.7MB Client: Shell (bash) inxi: 2.2.35

also, i use a SSD not a HDD

Try adding acpi_backlight to your boot settings.

First make a copy of the file your about to edit.

sudo cp /etc/default/grub /etc/default/grub.original

Now open up your text editor

gksudo pluma /etc/default/grub

And change this line


To read

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Run like that for a while, see if it helps.

I forgot, you need to update grub

sudo update-grub