Powermac G5 Dual 2.5 Fan Control HELP!

Intel

#1

Hello Everyone.

I’m new to this forum and very new to Ubuntu Mate and Linux in general.

The machine that I am currently using for this project is a powermac G5 dual 2.5 with ATI Radeon 9600 XT. I believe it was the very last powermac tower before Apple moved to intel processors. Full specs here https://everymac.com/systems/apple/powermac_g5/specs/powermac_g5_2.5_dp.html.

I have install Ubuntu Mate 16.04.1 LTS. On bootup I get a few errors (which I can’t remember at the moment), but my obvious concern is the fan speed. The fan winds up very high and stays that way. I have tried to use the power management settings with no success. Even if the screen saver comes on the computer never falls asleep.

I have read a number of posts about the fan issue, but have had no luck or understand exactly what to do. Has anyone else with the same situation found a solution for this particular machine? If so could you please explain to me, in detail please as I don’t have much knowledge, what I can to to fix this?

I would really like to bring this old computer back to life for the family to use.

Thank you


#2

Hi @saberx,

have you checked what the fan settings are like in BIOS/UEFI?. :smiley:


#3

Hi wolfman.

Thanks for the reply. I’m not sure how to do that. Can you offer any help?

I apologise again. I’m a novice.


#4

@saberx

You are lucky - your fan is working!
Using the old netbook with no chance of fan replacement makes me jelaous on you :wink:


#5

When you power on or restart the computer you have to enter the BIOS settings (must be written on the boot screen something like F2, F10, DEL)
Then try to find option for the fan.
On my system I can choose - constant but with reduced speed or periodical but with high speed.
Anyway, my netbook is old and I must do the “friendly help” to the fan to start work without BIOS. :slight_smile:


#6

Actually this being a PowerPC Mac, there is no such thing as BIOS/UEFI.
I used to run a G5 iMac, and that used something called “Open Firmware”, which is entirely command-line based and very cryptic.

Some hints about solving fan speed issues can maybe found here: https://www.macintouch.com/readerreports/powermacg5/topic2215.html or in similar threads.


#7

And it is easier to ask Ubuntu then the manager of fan factory? :smiley:
(just joke)


#8

Vladimir75

Thank you for the reply. I was able to get into the BIOS or Open Firmware
settings, but I have no idea if the settings can be modified or how to do
it. Any ideas? I do see a line that says /[email protected] but have no idea what that
means.

Thank you

BTW, I have just shut down the machine and reset the motherboard and reset
the PRAM. Nothing has changed.


#9

I am sorry, but I dont have Mac
Usualy there must be short factory explanation by side for the every single option that can be changed incuding with which keys on keyboard.
I hope it is same on your computer


#10

Thanks @maximuscore, I didn’t know that as I have never (and never will) used one!.

@saberx, follow maximuscores’s advice, I cannot help you further sorry!. :frowning:


#11

I understand. Thank you :slight_smile:


#12

Hello, a long rime returning to MATE. Your fan trouble happens to macs sometumes. The correct answer is to normally reset the PRAM, by – you ready? Physically remove the power cord from the back of your mac tower, go brew a cup of coffee and then plug it all back together and start over. Removing the power source completely for even the 15 minutes it took you to go get coffee resets the PRAM and should resolve your fan issue. If you even have this machine anymore.