PowerMac G5 - Sound - Fixed


congrats to the developers! I have been using elementary OS on my x86 workhorse for the last two years and wanted to give my G5 PPC I have not used much recently a new live. So I tried ubunta Mate 16.04 with a live CD and everything looked well except sound (and WiFi), where no device was listed.

I then carbon copied the existing OS X 10.5.8 installation to a new bigger harddisk, reduced that partition to a smaller size and let the ubuntu MATE installer do the rest as recommended. Everything looked and worked pretty well after installation, but again no sound at all. I am aware that there are quite a few posts in several forums and communities about the sound issue on PPC G5s and that this topic has been marked “Fixed”. But these solutions do not work for me / on my box.

First I had the typical common phenomenon with “dummy audio” being said and no audio device listed in system settings. Alsamixer crashed when selecting
Edit > Sound Card Properties
obviously because there was no sound card recognised.

On wiki.ubuntu.com/PowerPCFAQ it says the file /etc/modprobe.d/blacklist.local.conf should be deleted. But I do not have such file on my system. What I found is a blacklist.conf and seven more blacklists in this directory, but none of those seems to adress sound.

Then I added the following to /etc/modules:
As a result there is now a sound card listed in settings:
“K2 KeyLargo Mac/IO”
and both in settings and ALSA the device can be edited. But still no sound what ever the settings are.

btw: in OS X it says the sound card would be:
Texas Instruments TAS3004

pls help
thx in advance

You might try adding gnome-altamixer in terminal (use sudo apt install gnome-altamixer). Then run gnome-altamixer in terminal to set PCM to about 80%. When I had no sound, the things you did plus this installation fixed it on my PPC. I did not add the snd_aoa_codec_onyx to my modules file.

In terminal I got the reply gnome-altamixer could not be found.
What is the source of this app?
In settings I only have the sources canonical and launchpad activated.
[ Opended Ubuntu Software-Center to look there, but this is unbelievable slow. Still loading as I write this. Seems to be another malfunction. ]

Got it. It is alsamixer (not alta…). I already had that installed.
Set PCM as advised and that did not make any difference.
Then deleted the snd_aoa_codec_onyx entry … and now it works!! At least with headphones plugged in. Will let you know if this is a general solution.

I am really sorry about the typo. I usually re-read things like that
before hitting the send button.

thx again for your advise. Sound works fine now. Both with headphones plugged in in the front and speakers plugged in in the rear.

To all:
Solutions and fixes given in several forums look a bit inconsistent to me. On my box the one and only entry I had in the file /etc/modules (i.e. kernel modules to load at boot time) was:

Sound on my G5 PPC works well after adding the following lines to /etc/modules:

I had also added the following entry:
but this needed to be deleted.