PowerPC - Wireless not working with 16.04

Tried everything to get Wireless (aka “Airport”) running on my G5 PPC.

In my box I have an Airport Extreme
Chip ID: BCM4306
PCI-ID: 14e4:4320
Kernel driver: ssb

Tried the b43-driver. The hardware is recognised as soon as the network cable is disconnected. WLANs in reach are recognised correctly and the window for authentification shows up when selecting a network. But after entering the password nothing happens. No indicator for a successfull connection to the network and no connection established.

Then uninstalled the b43-driver in the terminal and installed the b43-legacy-driver but absolutely the same effect and results.

Did anyone get this up and running?

Yes, mine work fine. Did you load the b43 firmware? You need the Broadcom firmware from package firmware-b43-installer.

Check your syslog to see if there is some type of wifi error message.

BTW: Others here have noticed that you have to be quick with that password – 20 seconds IIRC.

thx a lot !! Now mine works fine as well.
I already had the b43 firmware installed. The wireless symbol on the top right was shown as soon as the network cable was disconnected, but no connection was established.

I now rebooted with the LAN cable unplugged, clicked on the wireless symbol and harried to enter the network key within those 20 seconds and it worked right away. But maybe the main aspect is that the network cable needs to be unplugged upon boot.

How can this post be marked “Solved”?