Printer Install trouble

I installed my Brother MFC-J470DW, using the .deb package provided by Brother. I have used this to install this printer on a number of different distros, and used the same procedure to install a friend’s Brother MFC-J4710DW earlier this week on both a LinuxMint laptop and a Ubuntu MATE desktop, all successfully.

But not this time. I did everything, it reported being installed, and did not print a test page as it should have. It reports being on the network, but I can’t get any print jobs to go there and print.

I have no idea if this is a problem with Ubuntu (even though it worked with a slightly different Brother printer on another friend’s desktop with me doing the installation) or if I did it wrong. I did repeat my steps, with the same non-result.

I guess I should mention my computer. I’m using a Lenovo ThinkPad T430.

You should also mention the version of Ubuntu MATE where it’s failing, ant the version of Ubuntu MATE where it worked.

They are the same versions, but on different machines. The machine where I had success was a Dell desktop, I do not know the model. MATE 1.12.1, I burned it to a DVD and used the same disk on both machines.


I just did an installation of elementary OS, didn’t like it, and went back to Ubuntu MATE. I was hoping a fresh start might fix this problem, but it didn’t. The printer setup ran beautifully, but it did not print a test page and does not work. As I have had no help here, I may have to go back to LinuxMint 18, where it worked fine. I have no idea why it worked on that Dell desktop under Ubuntu MATE (installed from the same disk).

One thing occurs to me, the printer may not be receiving content based on the wireless on the printer. It does report having an URI though… I just checked my network, and it reports as … on the printer is says 192,168.000.017 , is there a significant difference with the extra zeros?

OK, I just tried it without the extra zeros and the printer works fine, so that was my answer. Glad I figured it out.

1 Like