Printer pauses randomly after upgrade to 16.04

I’ve got 2 printers, an HP and a Samsung ML1660. The HP works fine, and the Samsung loads in printers but has a pause symbol on it, because it isn’t enabled. If I click on “enable printer” in the right-click menu, it goes away for about 10 seconds then comes back. I’m at a loss as to what’s going on here. I have tried reinstalling the printer from CUPS web interface and the system dialog(see below).

Also (might be a bug): removing the printer and reinstalling using the system dialog causes the dialog to freeze and not respond.

Which printer is set as default?. :smiley:

Did you install the Samsung unified printer driver?

(q.v. HOWTO: Configure the Samsung ML-1660 for CUPS )

That method appears to be out of date. I tried the current ULD driver from Samsung, and ran the included shell script, without any change, even with reboot.

Thought I’d found it by reinstalling the driver, but it didn’t work

Screenshot of the cups page, ~10 seconds after installing new driver and "printer found" popup. Is there a service that checks for printers, or a permission that gets set automatically? The timing seems suspicious, like it's a script firing off when something changed.

Hmm, here’s the end of the log file for cups, what’s gutenprint52? I found a reference to it being an issue on the arch forums, but if I try to uninstall it apt automatically wants to uninstall mate-desktop!

E [01/May/2016:11:04:23 -0600] [cups-driverd] Bad driver information file \"/usr/share/cups/model/uld-samsung/cms/M337xsc.cts\"!
E [01/May/2016:11:04:23 -0600] [cups-driverd] Bad driver information file \"/usr/share/cups/model/uld-samsung/cms/SCX-470xsc.cts\"!
E [01/May/2016:11:04:23 -0600] [cups-driverd] Skipping \"/usr/share/ppd/uld-samsung\": loop detected!
E [01/May/2016:11:04:42 -0600] [cups-deviced] PID 14996 (gutenprint52+usb) stopped with status 1!
E [01/May/2016:11:04:53 -0600] [cups-deviced] PID 15083 (gutenprint52+usb) stopped with status 1!
E [01/May/2016:11:05:04 -0600] [cups-deviced] PID 15179 (gutenprint52+usb) stopped with status 1!

It looks like there is an issue with a driver from what I’ve managed to dig up. This post may be useful to you. It sound’s like you need to blacklist usblp driver.

Gulp. I doubt it’s something that drastic, it worked last week on 14.04, and has been for some time.

Found the thread about gutenprint again: https://bbs.archlinux.org/viewtopic.php?id=208475

But attempting to remove libgutenprint2 gives me this:

[email protected]:~$ sudo apt-get remove libgutenprint2 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libgutenprint2 printer-driver-gutenprint ubuntu-mate-core
  ubuntu-mate-desktop
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
After this operation, 9,251 kB disk space will be freed.
Do you want to continue? [Y/n] 

It’s only 9mb to remove, so I don’t think that it’s trying to remove the entire core/desktop, is it saying that because the metapackage won’t be complete anymore?

yes ubuntu-mate-core and desktop only contain copyright and changelog files (q.v. dpkg -L ubuntu-mate-core). They are meta packages that pull in a host of other things. Your desktop functionality won’t change but it may cause issues when doing upgrades. If the maintainers add any packages to the dependency list you’ll have to manually add those files. If you upgrade to 16.10 it may not go as expected.

Removing gutenberg didn’t help, at least by itself. It would only pause if given a print job, but would never print and never resume. There’s two different drivers in what’s left, without the Samsung proprietary package, a plain one and 2.0.0. I selected the regular one, and now the printer will print- but only if manually resumed.

Edit: interesting update, it will print without pausing with .txt files, but pauses when trying .pdf, .dvi, .ps files

Voila! Lunch must have made the difference, 'cause now it works?!

nevermind…

1 Like

I have exactly the same issue, after upgrade to 16.04 Although I went for lunch and later for dinner, printer will pause.

Reinstalling it would print one job, I did not try more pages. I’ll do some more testing tomorrow.

Printer is a samsung clx-3300 series

Hmm, both samsung printers, I wonder if this makes for more than a coincidence?

I have opened bug #1584367 for this on launchpad

Hiya guys, thank God I found this thread.

My Samsung ML-1915 laser printer has been driving me nuts. After upgrading to LTS 16.04 everything looked fine but when I tried to hook up my printer it all went downhill from there. I had the same experience as you (Gutenprint Error 1, printer could be installed but not enabled for more than a few seconds, tried the ULD but still not being able to print at all).

Hope this gets fixed soon. It’s kinda ridiculous to create your docs under Linux but having to print them under Windows :stuck_out_tongue:

Cheers, Chris

I discovered a workaround: I wasn’t aware that downgrading a package is possible in ubuntu, if you know the exact version available in a repository. Since it worked in Trusty, I was able to locate the package and install it using

sudo apt install libgutenprint2=5.2.10~pre2-0ubuntu2

YMMV, but I hope this helps

2 Likes

Hiya fuzzy, sounds great. Would you mind explaining what you did exactly, however? I am being told that two other packages are going to be removed as well so I am not sure if I should proceed…

EDIT: So here’s what I did:

  • Went to http://packages.ubuntu.com/trusty/i386/libgutenprint2/download and downloaded the package “libgutenprint2=5.2.10~pre2-0ubuntu2” (in my case the i386 deb file)
  • Uninstalled libgutenprint2 (including the two other packages that are mentioned in the process) using sudo apt-get remove libgutenprint2
  • Installed the downloaded libgutenprint2 using the gdebi installer (double-clicking the file should do)
  • Ran sudo apt-get check to make sure there are no unmet dependencies
  • Locked the libgutenprint2 package using sudo apt-mark hold libgutenprint2 to keep it from being updated

2nd EDIT:

I replayed the steps above on my physical system but still no change so I’ll need to wait for a bugfix.

Cheers,
Chris

Sounds like you’re doing more work than necessary.
sudo apt install libgutenprint2=5.2.10~pre2-0ubuntu2 will do most of the steps you listed without affecting the rest of the system (merely downgrading a single package). This ensures that you’re not having to keep track of a .deb file as well. It does break a couple of meta-packages, which is the warning apt throws when you do this method, but that’s just because the meta-package is now incomplete.

Didn’t know about apt-mark, that’s good to know.

However, this didn’t fix the problem, only make it a little better (I can get it to print by clicking enable). I am still thinking that there’s a watchdog or something else running which is removing permissions from the printer driver, thereby disabling it. When it runs, it runs fine, so I’m unsure it’s actually the driver.

Hello All,
Ubuntu Mate has indeed a “printing” problem, e.g. with a Samsung ML1640 it shows the problem of making printing “unable” after a few seconds.
With a HP Office Jet 4500-510g-m printing succeeds for html-files and testpage but not for .doc/.pdf - nor .txt files, for the latter only blank pages got printed.
The “unable” problem has in this post already been mentioned a lot but till no solution has been found/presented jet.
Under UM 14.04 printing was no problem at all.
As UM 16.04 is a LTS this issue should not be present for a long time I presume so I may hope a fix is coming soon.
Regards.