Printing horrors - US Letter permanently selected

I have been using Ubuntu-Mate for several months, on several machines, and it has been great. I have now upgraded my main desktop, on which I do real work, to 64bit. (Its the same machine, but the original install was 32 bit, because there is a problem with the Intel Video driver choosing inappropriate video modes, and I discovered that it could be fixed by using displayport instead of HDMI).

The machine is dual boot, with both installations sharing the home directory.

Now the 64bit installation SOMETIMES wont print, because it greys out the paper size option, stuck in the “US Letter” mode.

THERE IS NO US LETTER PAPER IN EUROPE. There never has been, and never will be (outside the Xerox Development Research Labs). How long will it be before Software developers realise that for us Europeans, “US Letter” is not an option - it is a mission critical bug! If you are asked for US Letter, it means you are unable to print anything. Its a show stopper. It is unkillable. Your letters to suppliers, customers, the bank and the government cannot be printed. You are shafted.

I have one or two other, minor problems, but somehow, developers do not seem to realise that being stuck with “US Letter” is not a minor irritant, for us (half the world) is the same as having the computer completely broken!

I am saying this here, because

a) it is a UI problem - the UI does not let me change it
b) without understanding the entire Linux political scene, I cannot find out whether it is Mate, CUPS, Linux, OKI Printers or the Cookie monster that is responsible.
c) printing problems are a major obstacle to Linux acceptance - and UI changes are responsible for the majority of printer problems.

My solution is to reboot to 32 bit version to print - but it is pretty silly that this is the only way I can do it.

Whilst not a solution, the following will save you a bit of time whilst we try and find a solution:

Install your 32 bit version in virtual-box and have a shared folder between your 64 bit host and 32 bit client VM. That way, you can print without having to reboot your host.

I may not fully comprehend your situation.
I just checked my printing capabilities using HPLIP and discovered there are dozens of paper selections available, many of which are European ...

You clearly do not. The ability to change the selection is greyed out. (not
always, but sometimes, and for no obvious reason).

I have no idea if I am using HPLIP - I am using an Oki MC342, and I
installed the ppd myself.
It works fine in the 32 bit installation. It occasionally does not in the
64 bit installation - both of Ubuntu Mate Xenial on the same computer

  • so it is not hardware. It can, and does, print A4, and is now working
    fine! (Logged out, went away, came back 4 hours later, and logged in).

I have been a Unix user since 1978, but I have no idea where to start
looking for the problem.

My point was really not that there was a problem on this occasion, but
that, for the last 30 years, I have repeatedly encountered problems
relating to “US Letter” preventing, me, my friends, my family and my
colleagues for being able to print, and bug reports relating to
this are generally rated “trivial” when they are, in fact show stoppers.

I expect my problem will go away when something us updated, as, presumably,
there are many thousands of people affected by this. There
will probably be few bug reports. I was unable to find an official way to
report the bug before having to leave for a hospital appointment - so
I posted it somewhere where I thought people might be concerned about users
with a poor experience of Mate. I would like Mate improved,
and unless it mysteriously gets worse (Unity, I am looking at you), I will
probably stick with it, and continue to convert friends and family,
but being unable to print because the OS thinks it should be asking for US
Letter paper is definitely a show-stopper. They will demand
immediate restoration of Windows 7 or Ubuntu or go and buy a Mac.

Back to my original point - If your Locale is Europe or Africa, you
probably will not even know “US Letter” is a paper size. A great many
HP desk-jets were thrown away because when people saw the message “Load
letter” they assumed it was a fatal error - they had never
heard of “Letter paper”, and have no access to it. “Load letter” is not a
meaningful phrase this side of the Atlantic - unless it refers to the
transport industry.

During the installation process, all references to “US Letter” should be

There is no case for it to be present, and for the average user, the
consequences of it being chosen as some kind of default are on a
par with “rm -rf”.* It is not on a par with having “tms rmn” instead of
“Times Roman”* (but that is the way the bug reports generally
treat it).

That was my point.

best wishes


1 Like

I suggest that in the future, you do not have ubuntu installations share the same /home directory as there are .config files (and similar ‘hidden’ files) that may cause conflicts between versions. I learned this the hard way when I had multiple installations and mysterious occurrences like yours began happening.

Good luck acgrillet.


Hi mdooley

I have totally depended on doing this as a method of disaster recovery for
over 15 years! (I do have
tape backup as well). It is used to be standard practice, and I think those
responsible for design
decisions ought to know that. In fact, it used to be standard practice for
/home to be nfs served
to entire companies, so you could hot desk, and wherever you were, you had
the same setup.

OK, so I am talking BSD and Solaris, but I thought it was all supposed to
be the same.
Does Mate work on FreeBSD? Perhaps I should go back where I came from? I am
not going back to CDE on Solaris without a struggle!

AFAICR, at Xerox, there were separate nfs servers for /home/a, /home/b, etc
for the people
whose logins began with that letter - eg
(10 base t, and hard disks were probably still in megabytes then)

If your config is different, you should use a different file/directory:
I think most apps still get this right (LibreOffice, Firefox).

Incidentally, I an writing this from the 32bit install, cos the 64 bit one
has decided to go back to vesafb
instead of Intel, and it isn’t working (text mode consoles are OK -
sometimes). Wifi also not working.

Maybe I need a reinstall.

How about creating a second user profile (different names) in the 32bit
and the 64bit environments and test the printing options to begin with
and then maybe investigate/debug configuration files/setups after that?
I create a second Canon Printer for my printing of CD setup, a bit crude
but works, likewise once you have pinpointed the problem, you may be
able to have different printer profiles with each as a default for the
particular environments? My beef about Linux printer drivers would be
getting the colour balance right, Libre Office is almost correct out of
the box, GIMP is way,way out.


I usually have data partitions and soft link various directories on them to my home. I also don't quite understand how your OKI printer should be stuck on a paper size that you never use. Shouldn't it be stuck on A4 which you must've selected at some point in Printer Properties?

And perhaps this should be discussed in the Support section?

Those are good detective techniques robwlakes.

Hallo acgrillet

I also use an OKI printer (C310dn). It works better with Ubuntu-Mate than some versions of windows, at least as far as installing drivers is concerned. However, for Ubuntu-Mate there is a driver available in the supplied driver list. All I had to do was select it and that was that. Trying to find a driver for windoze 10 was a headache, although with help I got there in the end.
So just to clarify the situation, was the driver you installed from the list of “delivered with Ubuntu” drivers, or did you obtain it from another source?

Why do I use OKI? At the time of purchase I had a family member using a Mac, so the printer had to be Mac compatible and bring duplex printing as a printer feature. Once you get the drivers installed it’s a workhorse (to be fair it also makes more noise than a hard working horse ever would…).

Hi @acgrillet,

have you checked to see if your default language is any other than US English?:

1 Like

Letter is the fallback value used by programs if the file /etc/papersize does not exist. So make sure you have it and it contains just one line: a4 .

Man papersize says this value can be overridden with environmental variable PAPERSIZE, but it’s my understanding it’s more or less ignored by programs these days, in favour of /etc/papersize. But you could try it, of course, setting PAPERSIZE=a4.

Last resort is to edit your printer’s PPD file in /etc/cups/ppd/. Look for these two settings:

*OrderDependency: some_number AnySetup *PageSize
*DefaultPageSize: A4

Set the DefaultPageSize to A4 (if it’s not) and change the OrderDependency so that *PageSize is before AnySetup:

*OrderDependency: some_number *PageSize AnySetup

I must agree with @mdooley, sharing /home with two different architecture installs is not necessarily the best approach, since they can have different versions of some programs and some config options may have changed their names between versions. That said, most of it works - so if I was in a similar situation I would most likely find out the “bad behaving” programs that need different configs per architecture and use soft links or bind mounts (as suggested by @mdooley already) with some autostart script magic to make it work.

1 Like

I have a completely fresh install on a new hard disk, and I still have this problem.

If it does not happen with other printers (I think I have heard others complaining about it, but not certain)
then it might be the OKI PPD that is not OK. I had to edit it to add C6 envelopes, and after that, used the cupstestppd utility - there were a bunch of warnings in the original code!

However, I warn everyone OKI is not like it used to be - their software appears not to be compatible with Windows or Linux these days, and I don’t own a Mac.

I am not going back to 32 bit environments, although I do have a laptop running 32 bit, I think.

I remain shocked that after 50 years of using computers, printers are harder to configure than ever, and annoying in more ways than one could imagine!

And LibreOffice is absolutely plagued by solutions to problems which only work on the version from five years ago, because all the UI has been modified. Until there is a way to get Google searches to only search for what you asked for, all UI mods to all software , everywhere, should be blocked! (or maybe Google should be blocked :wink:

Perhaps this link will help -

Good luck @acgrillet.


I would like to offer you some entertainment to soften your pain:

Everyone should watch that movie, its a real eye opener!


Lovely - exactly on time - just had two false reports of “paper jam” - have
you ever tried spreading paper jam on your toast?

The entire LibreOffice and CUP teams should face an endless loop of it for
24 hours each morning!

Today’s problem is that I have C6 envelopes in the multi-purpose tray.

LibreOffice insisted that the only possible paper size is A4 (dropdown
greyed out) until I modded the PPD file (I used to write printer drivers
for Word perfect).

Then use use the Ubuntu Printer settings to select C6 paper - OpenOffice
now says C6 is the only option. You can only select landscape (which is
what I want).

However, the printer does not offer C6 as a paper setting for the MPT (Its
an MPT - there should be an option to feed whatever paper you put in it.
(Is that what Manual feed means? no).

When you tell it the paper is A6 (what fits in a C6 envelope) it will print

  • but in portrait mode! (OK, turn the envelopes round)

Finally, 24 hours later, I get to print my envelopes. (Ignore the week I
spent trying to find out how to do mail merge).

In the 1990’s I could do all this in minutes using a PDP/11 and an LA120 -
I even used to have my own print room with 6 IBM golf ball printers (noiser
than an overloaded 16 litre diesel truck going up hill). AND I worked for

If I can’t get this technology to work, who the hell can?



Good try, but no seegar!

Fine if I only had one paper size, but I routinely use many -
yesterday/today the issue was to print C6 envelopes. The printer can do it,
but it require me to modify the PPD,
set the paper size to C6 using the system printers dialogue, and then tell
the printer it had A6 paper in it. This printed in portrait instead of
landscape, and required
pressing “do you want to print on the wrong size of paper?” and “are you
sure” on the printer controls FOR EACH ENVELOPE. But I got the job done.

Yes I do know OKI is responsible for half of this mess (eg messed up PPD
that wont pass the Adobe testppd program, but realistically, Ubuntu and
LibreOffice are both
complicit in the mess. Why does not /etc/papersize allow entering all the
papersizes you might want (or, indeed, all you might wish to choose from)
and why does the
LibreOffice grey out valid selections? not just paper size, but
landscape/portrait and paper tray selection?

Has no one in the entire LibreOffice team ever tried to print anything
except plain paper?

It is about time that the world realised that people make the decisions
that lead to this kind of filthy mess, and blamed them. Never mind “fat
shaming” the OKI design team involved
should be dragged out into the main square and forced to wear headbands
saying “I worked on the OKI MC342 PPD design” and the video show on

Have to go: Another mail-merge is calling - and it needs a watermarked
background. Pass the Panadol and a triple expresso.



That is funny as hell…:grin:

Glad you liked it :smile: