Printing Woes with 20.04 finally solved USB cable-connected printer

This applies to a USB printer connected to a computer with a USB cable, not wifi, for which you might have a ppd file. And it bypasses the "glorious" ipp protocols.

Before I start, there's a helpful page here:
Ubuntu wiki for printer problems
That page helped a LOT.

Using the tail command (above link under USB printer) and reading further down in the page and with some experimenting, there is an important step. Install apparmor utilities and run:
sudo aa-complain cupsd

But do NOT get carried away and try the same command with cups-browsed. That took an hour or two away from my life.

After a day's worth (just this week) of trying everything I could think of, including setting ippusbxd to complain mode in apparmor (doesn't work either), and trying various permission changes, I ran across the fix.

Yes, CUPS wants to deprecate drivers and go all IPP with printers; however, that part of Ubuntu seems to be broken when there is a simple printer plugged in to a simple USB port. Just when I was about to think the solution was to have a tiny extra computer connected to the printer running some version of the big monster from near Seattle, I found the solution.

I totally removed ippusbxd. If you have a USB printer hooked to your computer, which I do, then you do NOT need to be constantly "browsing" for a "network printer". It's broken, Ubuntu. You need to fix it. But meanwhile, there's STILL the possibility to connect via USB and load the ppd file and actually print.

This has been a back and forth headache since I installed Ubuntu Mate in the Summer. It works. It quits working. Reboot and get those few pages printed. Turn the printer off and back on. Pause and restart in CUPS via the browser. On and on and on until two days ago it just quit seeing the printer almost TOTALLY. Or I'd have THREE printers.

So, in summary, what seems to be the solution:
Set cupsd to complain only mode in apparmor.
Remove and purge ippusbxd.

Hope this helps someone else save the couple of days of searching and head-desk I've spent since last Summer, including a full day this week.

I was unable to get my Epson printer to work unless it was connected via usb. Thumbs up.

Hello Amigo

I presume you know about:

Just on the off chance that you missed it. :slightly_smiling_face: