Problem after locking screen when logged in as user without login password

When I create a user and I check the option "Do not ask password when logging in", not only I still have to enter a password to create the user, but I also have to enter a password when the user locks the PC. If a user that has that option enabled it makes sense that I can unlock the PC without a password. I am using 18.04, maybe this is fixed in 19.10?

It's actually by design, users (and especially the superuser, root/sudo) should have passwords for security reasons. Checking "do not ask password when logging in" does exactly that, but locking the screen will ask for the password as the user has one set. :lock: :key:

To remove the password, you'll need to use the Terminal - for a standard user, this will do:

sudo passwd -d nameofuser

:warning: However, if the user is an administrator (sudo), then you must perform another step first, otherwise you'll lock yourself out from administrative tasks!


sudo visudo

And add a line (changing nameofuser) to the bottom of the file:


Then you may proceed to use the passwd command above.

If you don't have a user with sudo privileges, you'll lock yourself out as sudo (or anything asking for a password) will not accept blank passwords.


1 Like

This is bad design. If a user can log in without a password, he/she should be able to unlock the PC without a password, even if he/she has a password set.

It's down to roots of Linux (and Unix-like operating systems) being a multi-user system.

I disagree about it being bad design. The user password is essential for encrypting passwords in the keyring (like saving passwords in Chrome/Chromium and some other programs), otherwise anybody with access (or any dodgy program) could read them.

Security vs convenience. :male_detective:

I just remembered, the more secure way would be to keep the password but uncheck "Lock screen when screensaver is active" in the Screensaver options. That way, if it's the screen saver that causes the unwanted locking, it'll just be blanking the screen instead. :unlock:

The bad design isn't that I have to enter a password to create the user. The bad design is that I have to enter a password to unlock the PC when I didn't have to enter the password to log in in the first place.

Just so you know... Windows 10 and Mac have the same behaviour...

Assuming a user has a password set, with auto login enabled:

  • Windows: 7/10: Using netplwiz command.
  • Mac: Start-up Options under User & Groups.

Both of them will ask for the password after the screensaver if:

  • Windows: "On resume, display log-on screen" is checked setting a screensaver.
  • Mac: "Ask for password to unlock [...]" checkbox is checked under Security & Privacy.

The thing is, both of them uncheck that by default, whereas MATE Screensaver does.

When can I make the screensaver not ask for a password to unlock the PC? I can't find the option anywhere.

System > Preferences > Look and Feel > Screensaver. Uncheck "Lock screen when screensaver is active".