Problem Boot after installation

Hello,

I am new in the ubuntu environment. Following a 1st attempt to migrate from windows to Ubuntu MATE where everything went very well, I repeated the experience with another computer where windows was pre-installed.
The disk was voluntarily erased at the time of the installation to have only one environment and not to have dual boot and the computer seems to be configured in EFI mode.

Since the installation at each startup the computer struggles to launch. Indeed, I am obliged to boot several times (3, 5 or 7 times) so that finally grub appears and allows me to try to boot in normal or Rescue mode.

As a result, when I turn on the computer for the first time in the day, there is just a gray screen, I force it to shut down and as soon as I turn it back on it comes up with GRUB and offers me two generic environments and two modes without failure.
From there, whatever the chosen environment, it continues immediately on :

Loading of linux 5.8.0-25-generic...
Loading the initial memory disk...

And then, nothing more.

After several startups, it starts correctly in a completely random way either in normal mode or in safe mode and once started, everything goes very well.

I reinstalled 3 times Ubuntu MATE then I tried xubuntu to see if it came from the operating system but each time it's the same for ubuntu MAATE and xubuntu

You will find below the report of the boot-repair application:

boot-repair-4ppa130 [20210419_0914]

============================== Boot Info Summary ===============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/BOOT/bkpbootx64.efi /efi/BOOT/bootx64.efi 
                       /efi/BOOT/fbx64.efi /efi/BOOT/grubx64.efi 
                       /efi/BOOT/mmx64.efi /efi/ubuntu/grubx64.efi 
                       /efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi 
                       /efi/ubuntu/grub.cfg

sda2: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 20.04.2 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub


================================ 1 OS detected =================================

OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.2 LTS CurrentSession on sda2

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.4.0-72-generic root=UUID=f894d6af-339c-4d8f-94d6-95d1c3ceb5d8 ro quiet splash


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0004,0005,0001,0000
Boot0000* Windows Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...9................
Boot0001* Windows Boot Manager	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...3................
Boot0004* ubuntu	HD(1,GPT,eeb5ae48-ea7d-412b-b9ad-54ab80eebbbb,0x800,0x100000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0005* ubuntu	HD(1,GPT,eeb5ae48-ea7d-412b-b9ad-54ab80eebbbb,0x800,0x100000)/File(\EFI\UBUNTU\GRUBX64.EFI)..BO

78415fb8fb9b909f8029858113f1335f   sda1/BOOT/bkpbootx64.efi
78415fb8fb9b909f8029858113f1335f   sda1/BOOT/bootx64.efi
2895d47544fd587b26c7e29be1295c27   sda1/BOOT/fbx64.efi
d8b4b9ae3018b1f4612611be7f42507a   sda1/BOOT/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   sda1/BOOT/mmx64.efi
957dc7e5f72c1d7393bf7850df5db2db   sda1/ubuntu/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   sda1/ubuntu/mmx64.efi
78415fb8fb9b909f8029858113f1335f   sda1/ubuntu/shimx64.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda2	: is-os,	64, apt-get,	signed grub-pc grub-efi ,	grub2,	grub-install,	grubenv-ok,	update-grub,	not-far
sda1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far

Partitions info (2/3): _________________________________________________________

sda2	: isnotESP,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

sda2	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	sda
sda1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda

fdisk -l (filtered): ___________________________________________________________

Disk sda: 29.83 GiB, 32008606208 bytes, 62516809 sectors
Disk identifier: 7200EC06-B8C0-4BEF-92C4-C87A03A94946
        Start      End  Sectors  Size Type
sda1     2048  1050623  1048576  512M EFI System
sda2  1050624 62515199 61464576 29.3G Linux filesystem

parted -lm (filtered): _________________________________________________________

sda:32.0GB:scsi:512:512:gpt:ATA :;
1:1049kB:538MB:537MB:fat32:EFI System Partition:boot, esp;
2:538MB:32.0GB:31.5GB:ext4::;

blkid (filtered): ______________________________________________________________

NAME   FSTYPE   UUID                                 PARTUUID                             LABEL PARTLABEL
sda                                                                                             
├─sda1 vfat     894D-55E8                            eeb5ae48-ea7d-412b-b9ad-54ab80eebbbb       EFI System Partition
└─sda2 ext4     f894d6af-339c-4d8f-94d6-95d1c3ceb5d8 de88cad5-e410-4157-97cb-86fc2adbd2a5       

df (filtered): _________________________________________________________________

                   Avail Use% Mounted on
sda2              754.4M  92% /

Mount options: __________________________________________________________________

sda2              rw,relatime,errors=remount-ro

===================== sda1/efi/ubuntu/grub.cfg (filtered) ======================

search.fs_uuid f894d6af-339c-4d8f-94d6-95d1c3ceb5d8 root hd0,gpt2 hd0,gpt2 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

====================== sda2/boot/grub/grub.cfg (filtered) ======================

Ubuntu   f894d6af-339c-4d8f-94d6-95d1c3ceb5d8
Ubuntu, avec Linux 5.4.0-72-generic   f894d6af-339c-4d8f-94d6-95d1c3ceb5d8
Ubuntu, avec Linux 5.4.0-70-generic   f894d6af-339c-4d8f-94d6-95d1c3ceb5d8
Ubuntu, avec Linux 5.4.0-64-generic   f894d6af-339c-4d8f-94d6-95d1c3ceb5d8
Ubuntu, avec Linux 5.4.0-62-generic   f894d6af-339c-4d8f-94d6-95d1c3ceb5d8
Ubuntu, avec Linux 5.4.0-60-generic   f894d6af-339c-4d8f-94d6-95d1c3ceb5d8
### END /etc/grub.d/30_os-prober ###
UEFI Firmware Settings   uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

========================== sda2/etc/fstab (filtered) ===========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=f894d6af-339c-4d8f-94d6-95d1c3ceb5d8 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
/swapfile                                 none            swap    sw              0       0
UUID=894D-55E8  /boot/efi       vfat    defaults      0       1

======================= sda2/etc/default/grub (filtered) =======================

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

==================== sda2: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
  19,499557495 = 20,937490432   boot/grub/grub.cfg                             2
  12,246040344 = 13,149085696   boot/vmlinuz                                   2
  29,316547394 = 31,478403072   boot/vmlinuz-5.4.0-60-generic                  2
   9,052486420 = 9,720033280    boot/vmlinuz-5.4.0-62-generic                  5
  11,001808167 = 11,813101568   boot/vmlinuz-5.4.0-64-generic                  5
  21,715049744 = 23,316357120   boot/vmlinuz-5.4.0-70-generic                  2
  12,246040344 = 13,149085696   boot/vmlinuz-5.4.0-72-generic                  2
  11,001808167 = 11,813101568   boot/vmlinuz.old                               5
  19,977535248 = 21,450715136   boot/initrd.img                               39
  19,932640076 = 21,402509312   boot/initrd.img-5.4.0-60-generic              39
  29,387447357 = 31,554531328   boot/initrd.img-5.4.0-62-generic              92
  18,589206696 = 19,960008704   boot/initrd.img-5.4.0-64-generic              92
  25,524410248 = 27,406626816   boot/initrd.img-5.4.0-70-generic               9
  19,977535248 = 21,450715136   boot/initrd.img-5.4.0-72-generic              39
  18,589206696 = 19,960008704   boot/initrd.img.old                           92

===================== sda2: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 17622 nov.  13 00:15 10_linux
-rwxr-xr-x 1 root root 42359 nov.  13 00:15 10_linux_zfs
-rwxr-xr-x 1 root root 12894 juil. 31  2020 20_linux_xen
-rwxr-xr-x 1 root root 12059 juil. 31  2020 30_os-prober
-rwxr-xr-x 1 root root  1424 juil. 31  2020 30_uefi-firmware
-rwxr-xr-x 1 root root   214 juil. 31  2020 40_custom
-rwxr-xr-x 1 root root   216 juil. 31  2020 41_custom


Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
sda2,
using the following options:        sda1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s  use-standard-efi-file  restore-efi-backups  

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.2 LTS CurrentSession entry (sda1/efi/****/shim****.efi (**** will be updated in the final message) file) !

Hi :slight_smile:
Can you try to set up the bios to boot only on legacy mode and next trying to install the OS again ?

Yes !!!! you are great !!! You have found the solution thank you so much !
Actually, I installed only one other time ubuntu MATE on an old computer and I did not have this problem...
Think you so much and have a great day
Alex

You welcome :slight_smile: Have good time with Ubuntu Mate :slight_smile: :ubuntu_mate: