Problem connecting two ubuntu mate computers with rsync and/or file manager

Hi A couple of weeks ago I installed Ubuntu Mate 17.10.1 on two computers. A hp envy desktop and a new hp laptop.
I can send a single file with rsync from either computer to the other, but if I try to copy a directory that contains files from one computer to the other with rsync it sends the directory structure but hangs and sends no files, printing “sending incremental file list”.
(These computers are on the same LAN.) I killed the process with Ctrl-C. I get: ^Crsync error: unexplained error (code 130) at rsync.c(644) [sender=3.1.2] rsync: [sender] write error: Broken pipe (32)
I can log in via ssh from my desktop to the laptop in the terminal and move around the filesystem. When I cd into a directory that contains a number of files and do “ls” it prints the file listing and then hangs. Can’t kill it with Ctrl-C. Ctrl-D gives:
packet_write_wait: “Connection to port 22: Broken pipe” and then I get my shell back.
Also, I can’t use caja or nautilus to connect from one computer to the other either, which has always been my method of choice (it just times out eventually), although caja works with no problem connecting to my wife’s macbook. I guess this is probably an ssh problem, but I can’t find any way to fix it after a lot of searching. Any help is greatly appreciated. Thanks

Try Filezilla to transfer files/folders between computers connected thru ssh. Works really good on my two computers which are connected via cross over Ethernet cable. You can use Wifi or Ethernet to connect. Lots of info online on ow to do this.

I just tried that, connecting with sftp, it timed out after 20 seconds, and failed to get directory listing. Filezilla works with a macbook just file. Also caja works with mackbook.

Just a quickee. See if you can whittle down the ls command by the alphabet and see if some filename character is doing that. I’ve also seen permissions affect my rsync backups like that. Or is it directly related to number of files? How many files do it?

I just tried filezilla, again. I just ssh’d into my laptop from my desktop. This thing is making a liar out of me. Yesterday I could not get “ls” to work properly (that is, without hanging). Today, just a minute ago, it seems to work perfectly. I moved around into several directories and listed the contents and everything is as it should. I have not done any changes to either system since yesterday. Connecting with filezilla, I get this:
Status: Connecting to…
Status: Connected to
Status: Retrieving directory listing…
Status: Listing directory /home/david
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

So, it is connecting, but will not do anything else. Whatever is causing this is probably causing the problem with caja, etc. My file permissions on /home (for both computers) are:
drwxr-x— 34 david david 4096 Feb 2 17:51 david

I just tried rsync again. It sent the dir structure, then one file, then just stops doing anything.
After tow Ctrl-D’s, then a Ctrl-C, I get this

rsync -avh /home/david/Pictures [email protected]:/home/david/Pictures/
sending incremental file list
^Crsync error: unexplained error (code 130) at rsync.c(644) [sender=3.1.2]
rsync: [sender] write error: Broken pipe (32)

There’s a lot of results searching “rsync error: unexplained error (code 130)” info but it looks rather general. It disconnects or something.

I’m not fresh on rsync but a review of scripts I did years ago looks similar except I have a -e ssh to point to a remote ssh shell. This is all working on 16.04 daily but things change, unfortunately. Haven’t used 17.10 for this.

I have used 16.04 and later upgraded to 16.10 and used it with no problems like this. I’ll keep working on this for a few days anyway. Thanks for your help. david

I think that I am starting to get a clue. I can’t believe I didn’t think of this earlier.
I connected via ethernet and everything works perfectly. Both the file manager and rsync.
So the problem is my wireless setup. It had been working so good with general internet
browsing that I did not even consider the wireless aspect. I have a Netgear Nighthawk X6 R8000
router which has been performing very well (as far as I can tell).

These are some messages from dmesg:
[113411.132547] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[113411.176639] r8169 0000:03:00.0 enp3s0: link down
[113411.176704] r8169 0000:03:00.0 enp3s0: link down
[113411.176721] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[113411.177401] IPv6: ADDRCONF(NETDEV_UP): wlp2s0f0: link is not ready
[113411.310756] IPv6: ADDRCONF(NETDEV_UP): wlp2s0f0: link is not ready
[113411.371801] IPv6: ADDRCONF(NETDEV_UP): wlp2s0f0: link is not ready
[113412.763204] r8169 0000:03:00.0 enp3s0: link up
[113412.763213] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready

At least I can use ethernet for data transfer until I get the wireless figured out.

1 Like