Problem mounting USB device Ubuntu MATE 15.10

I’m new to Ubuntu mate and i’m already having trouble mounting any usb device (from pendrives to headphones). System seems to detect devices but shows a “can’t mount file” message when trying to open it.

Please help, i’m totally a newbie to any Linux OS

Hi @erizodemar,

when you removed the USB from a different operating system like Windows or a different PC, did you just pull the USB stick out or did you use the “Safely remove function”?:

Won’t lie, i’ve “unsafely” removed the USB before. Is formatting the only solution for getting Linux read USBs again (although them work perfectly on Windows)?

1 Like

Put the USB stick back in the last PC it was used on using the same OS and then safely remove it, then reboot back into Ubuntu and try it!. :wink:

Still not working :cry:

Is it working under Windows?

Works perfectly in Windows

Is there any data on it and if yes, what type of data? . If you don’t need the data, copy it to Windows then format the drive to FAT32 then copy the data back and safely remove it and try it with Linux again! :smile:

Just some school papers, photos and music. Guess i have to do a backup in windows and format; theres no much i can do besides that.
Thank for your priceless help @wolfman !

1 Like

No problem @erizodemar, please let us know you get on so it helps others!. :smiley:

1 Like

It sounds like the partition is dirty. You could have tried mounting it using Disks (under Accessories), as it appears the file browser couldn’t automatically mount it.

If that still didn’t work, you’d have to manually mount it: Using Disks, take note of the /dev/sdXY and then run:

sudo mount -o ro /dev/sdXY /mnt

(Replacing sdXY with your flash drive – e.g. sdb1)
(The option -o ro mounts it as read-only)

Make sure the drive is already unmounted first.

Beware that unplugging drives without unmounting or ejecting them first can lead to data loss – especially on Linux – as data floats about in memory before it is written to disk. Windows by default writes the cache more often.


If it’s a large USB stick it may be formatted as exfat. Do you have exfat-fuse installed? You can quickily check in the terminal with apt search exfat-fuse if it is you should see this.

exfat-fuse/xenial,now 1.2.3-1 amd64 [installed]
 read and write exFAT driver for FUSE
1 Like

Sorry for not answering in a long time, I’ve been busy with some college issues lately.

I tried to format the usb stick from Windows and it still did not work. Then, i formatted it using Disks in Ubuntu and it worked perfectly!!!

Thank you all for your help.