Problem opening caja folders from programs

Hi

I am loving the Ubuntu mate 15.04 so far but there are just few problems.

If any program tries to open folders in Caja then Caja will just fail to open the specific folder and pop up a error message box saying “The folder contents could not be displayed”. Opening folder from Playonlinux will display that error.

To reproduce the problem using PlayOnLinux.

If you have existing wine prefix in PlayOnLinux then just click on “Open the Directory”. Caja will then pop up and say that the folder is not found but If I manually navigate to the folder it is there.

And the error message shows

However it is not PlayOnLinux problem as I have tried on Ubuntu Unity and Linux Mint Mate and it open fine. If it open fine on Linux Mint Mate maybe this suggest it is not Caja problem?

It is same in Transmission but it is quite weird in transmission.
When I download a torrent file and then I clicked on it to open up Transmission and then it throws up error message saying “Error opening torrent. The torrent file /tmp/fileB77azz” contains invalid data.". However I can start the torrent fine and it downloads no problem at all. Weirdly this only happens IF the torrent file contains folders that is to be downloaded.
The torrent file is not in tmp so I don’t know why it saying tmp location. To reproduce this problem just find any torrents file that would create folders and download the torrent file using chrome and open the torrent FROM Chrome. I get no error message when opening torrent file in Caja.

Also another thing… I am not 100% sure but it seems that xdg-open is bit messed up on Ubuntu Mate. For example chrome doesn’t know what program to open for torrent magnet links however on Ubuntu Unity and Linux Mint Mate it works out of box.

Sorry for the long text and I hope that makes sense.

Thank you.

Hi,

open Control Center > Personal > Preferred Applications > System and check your settings there:

Hope it helps. :smiley:

Hi

Thanks for the reply :slight_smile:
However I just checked and it is already set to Caja.

Virtualbox is also affected. if I right click on any virtual machines and then click on “Show in File Manager”. It also displays that error message “The folder contents could not be displayed.”

I have also tested it on another computer with clean installation and the error message is still there so I know it is not my computer.

This problem does not exists on Ubuntu Unity.

Thanks

Ok I did some searching around and it seems to be the XDG-OPEN problem.
I had a look at https://bugs.launchpad.net/linuxmint/+bug/1001902 And I have seen that Wimpy has also added Ubuntu Mate as being affected by this bug.

I have added “elif [ x”$MATE_DESKTOP_SESSION_ID" != x"" ]; then DE=gnome;" to the /usr/bin/xdg-open and it actually resolved all of the issues that I have mentioned in my first post.

But surely others must be also affected by this issues? I find it quite surprising that no one has mention this. I did try a clean install of Ubuntu Mate 15.04 on another machine and the issue is there unless I add that line to the /usr/bin/xdg-open. I did try Ubuntu Mate 14.10 and that was also affected.

I had a look at Linux Mint Mate /usr/bin/xdg-open and they don’t have that line however they added a workaround which is “else DE=gnome”. In Ubuntu Mate it is else DE="". Just blank.

Maybe we should consider add the same workaround to Ubuntu Mate?

Sorry for being a pain but would be good to get this issue fixed.

1 Like

That’s one for the devs, I have a small problem with the Clearweather Screenlet not starting, it works with Ubuntu Unity but not with Mate?.

Sorry I cannot be of more assistance!. :sob:

Don’t worry maybe we can report our issues to devs. I will wait couples of days if anyone else has something to say and then I will try report directly to devs.

I tried to look for clearweather screenlet just to test to see if it works for me however I can’t seem to find any working PPA and some old gnome apps site are down.

Hi Jonty,

try this:

It works; it is just that it won’t launch automatically on my Nvidia PC, it runs fine on my ATI rig!. :smiley:

Hm weird it works for me. I don’t think nvidia driver has anything to do with it but then I not sure sorry.

It isn’t a real problem as I just click on the screenlets launcher and it starts, it works fine on Ubuntu Unity 15.04 and Debian 8 and as I said before, on my ATI rig!. :smile:

Have you got any closer to solving your problem?. :smiley:

I downgraded to UM 14.04 and the Clearweather screenlet starts no problem, I think I’ll leave as is and skip using 15.04!. :smiley:

Ahh ok weird that 14.04 fixed for you but at least it working for you :smiley:

Yes I did fix the issue but I have PM Wimpy as that workaround is not included in Ubuntu Mate (Linux Mint Mate workaround I mean).

Does the issue affect you?

Hi gravy45,

what does the patch do?. :smiley:

@jonty789,

I don’t have a problem with UM15.04, except the screenlet not starting, thats it really, everything else works fine!. :smiley:

@gravy45,

thanks for the clarity!. :smiley:

I will be trying really hard to address this issue in 15.10. As @gravy45 points out the issue is actually in xdg-open.

Ah ok thank you :smiley:

Ah cool thanks for the tip. PlayOnLinux insists on using xterm but I would prefer to use mate terminal as it is better.
I don’t want xterm but it seems Steam has installed it in first place and if I try to remove it then it will remove steam and xorg off :frowning:

Oh well not a big deal.