Problematic update for Compiz desktops on 15.10

compiz

#1

Unfortunately, a recent update has caused issues for some users using Compiz as their window manager. After updating, you may discover a missing pointer or large X cursor.

Bug report concerning the issue:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1544814

Package Version

Affected: 1:0.9.12.2+15.10.20151202-0ubuntu1
Previous: 1:0.9.12.2+15.10.20151015-0ubuntu1

Unaffected:

  • Some Compiz users may have no issues
  • Marco
  • Compton

What should you do?

If you do not use Compiz or kept the default settings, you do not need to do anything.

If you haven’t updated, uncheck any updates for Compiz to avoid trouble.

If you have updated and are now experiencing cursor problems, the workaround is to switch to Marco via MATE Tweak or downgrade Compiz.

Downgrading Compiz is as simple as pasting this command into the terminal:

sudo apt-get install compiz=1:0.9.12.2+15.10.20151015-0ubuntu1 \
compiz-core=1:0.9.12.2+15.10.20151015-0ubuntu1 \
compiz-gnome=1:0.9.12.2+15.10.20151015-0ubuntu1 \
compiz-plugins-default=1:0.9.12.2+15.10.20151015-0ubuntu1 \
libcompizconfig0=1:0.9.12.2+15.10.20151015-0ubuntu1 \
libdecoration0=1:0.9.12.2+15.10.20151015-0ubuntu1

Sorry for the inconvenience.

New bugs caused by updates can happen, but are generally rare. :frowning:


pinned globally #2

#3

I could not see how a more concise wrap-up could have possibly been written for this chapter, @lah7; no one would ever be able to tell what confusion you had to, first, go through to get to this point :dizzy_face:!

Thanks for going over & above on this one :wink:!


#4

Thanks, again, for bringing this to the forefront, @lah7, it’s getting plenty of good nurturing, now! :construction_worker:

I could not imagine this site without you, and your follow-through! :guardsman:


#5

@lah7 & @Wimpy,

This bug does not exist on 16.04 via the same, affected, computer! :raised_hands:

Thanks again!


#6

I have committed a fix for this issue in Ubuntu 16.04, but it is not released yet. Should be in the official archive in a couple of days. I’ve also applied the same fix to mate-settings-daemon in the wily-mate PPA which carries MATE 1.12.

If you are affected by this Compiz issue on Ubuntu MATE 15.10 my advice is to add the wily-mate PPA and upgrade to MATE 1.12.

sudo apt-add-repository ppa:ubuntu-mate-dev/wily-mate
sudo apt-get update
sudo apt-get dist-upgrade

If you have a hidden file in your home directory called ~/.Xdefaults, you should rename it to ~/Xdefaults, to “disable” it.

mv ~/.Xdefaults ~/Xdefaults

Those of you already using the wily-mate PPA will get the fix via updates :slight_smile:

You will need to log out/in to make the fix fully effective. You may also need to use the Appearance control applet to set the xcursor (mouse pointer) size.


#7

I know that, when it presented, this bug effected various systems differently; and, refreshingly, some have conquered it without a fix.

Over here, subsequent to a 16.04 install, the three affected UMATE systems (two Dell PC’s and a Lenovo laptop), were effectively healed of any traces of pesky cursor behavior.

Indecently, the UMATE-Xenial installs on our systems, have even taken away a Linux-wide, multi-colored/themed (redglass/DMZ-white) combo-cursor bug, that was starting to get some internet coverage; so that’s really cool too!. :smiley: This bug caused the pointer to switch back and forth from redglass to DMZ-white erratically.

Thank you doesn’t quite seen adequate vis-à-vis the tremendous work I have witnessed here; hence, I should add that:

16.04 is a masterpiece!


closed #8

This topic was automatically closed after 15 days. New replies are no longer allowed.