Problems installing HP m29w printer/scanner for wireless use

My OS is UM 19.10 on an Intel based box.

I saw that I need at least HPLIP 3.18.4. My installed version was 3.19.6. So everything seemed OK. Used synaptic to install hplip-gui.

Plugged in usb connector from printer. It was recognized automatically.

I then brought up the hplip-gui and attempted wireless setup using hplip toolbox; selected network, entered network pwd, process appeared to complete successfully, but inspection of router did not reveal a new device so it appears that no IP was in fact assigned. Here is the resulting summary from hplip-gui.

address mode: dhcp
host: NP18F4221
ip address: (null)
gateway address: (null)
DNA address:

I am hoping that someone has had a similar experience and can point me to my error. - Thanks.

Hi astrogenealogist,
Similar, but not with HP, tought in Epson and canon seems same issue with router-printer wifi joining. Printer drivers manainers don't focuse enough in linux, almost not what it have to be, so that is the result. In Epson for me was a nightmare, googling lot of time, since finally any process didn't works. Hate to admit, but I had to install printer wifi drivers by window$. Once the process was completed obtaining IP, I could normally use printer wifi in ubuntu, also in android app. I must add IP in a few files manually before. Hope it helps you but I know it's not a great answer, maybe a workaround.

Hi Tim,
Thanks for the reply. - I have finally solved the problem. A description follows. And, yes, I have fought with Epson printers before as well. I found drivers for Linux that worked via the Epson website.


I completely removed the existing hplip components using synaptic. Then I executed the 3.20.5 install script. (This turned out to have been unnecessary.) - sh

On this machine, I have a direct ethernet connection and can activate a wifi connection as well. I did that. I was able to then connect to the wifi network that the printer offers. I could then see the laserjet printer and connect to it and configure it for use on this machine using the normal “printers” dialog/app inside UM.

On another machine, without a direct ethernet connection, I connected to the laserjet network and invoked, which is the wifi direct address shown on the printout that is generated using a button on the printer itself. See the “mobile printing” section of the printer user guide.

Then I navigated to the network/wirelessconfiguration page and set up coordination with the main network managed by my router. This resulted in the printer being available via an IP address on my main network. I could then connect to the main wireless network and connect to an use the printer. Hooray!!!!

Here is an example of the page used above after the printer was “joined” to the main network.

This makes it much easier to configure the printer on other machines. (Whew!)

So, in summary, here are the steps to getting the new n29w printer on your local network.

  1. Use the hplip facilities to configure the printer via a usb connection.
  2. Again, use hplip to configure it for wireless use. - The “wireless/wifi setup using usb” option
  3. use the printer’s touchpad to generate a report on its configuration. This will reveal the ip address to use to connect to the printer’s onboard config facilities. See the wifi direct part of the report.
  4. Use the onboard config UI to set up coordination with your local network. Using the “network” tab, use the “wireless configuration” page to do this.
  5. With the printer on the local network, use the “printers” app in UM to discover and configure the printer for use by all.

(BTW, to do any scanning with the M29w, I use Vusescan software from This avoids problems configuring xsane access.)

This is just a warning that as of yesterday (June 8, 2020) upgrading from 19.10 to 20.04 will render this printer useless via usb connection. Refer to Hplip missing files .