Prompt to upgrade 21.04 to 21.10 does nothing

I got an email that Ubuntu Mate 21.10 was available, so I started up a Mate VM. As soon as the system booted, a prompt appeared on my desktop:

"A new version is available would you like to upgrade?" I clicked the OK/Yes button. The prompt disappeared, but nothing happened.

So, then I started Software Updater. It showed me a small number of available updates were available, so I thought perhaps that was what caused the original upgrade not to work. I applied the available updates. When finished, without further action on my part, Software Updater then showed me a message that said:

"The software on this computer is up to date. However Ubuntu 21.10 is
now available (you have 21.04)."

Again, I click the Upgrade button, and again, nothing happens. I can now repeat this Software Updater process repeatedly, with the same results. I looked at many different system log files: syslog, kern.log, dmesg, dpkg.log, Xorg.0.log, apt/history.log. I can't see anything obvious that explains why these upgrades just disappear without doing anything.

I tried rebooting to see if that might change the outcome. Upon reboot, I no longer see the prompt on my desktop on system startup. However, using Software Updater produces the same result described above.

Before I drop to the command line and start with do-release-upgrade, since I'm in a repeatable failure mode, I wanted to offer up the opportunity to debug why this is happening. Since I can't find any applicable messages, I'll need some guidance on what to do next.

Thanks.

After a couple weeks with no reply, I dropped to the command line to figure out what the issue is. I'm including the solution here in case others find this post via search.

(1) I first ran Software Updater to make sure the installation was up to date.
(2) As root:

do-release-upgrade
Checking for a new Ubuntu release
Please install all available updates for your release before upgrading.

(3) So, even though Software Updater says everything is up to date, do-release-upgrade thinks otherwise. So again as root:

apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
ayatana-indicator-datetime ayatana-indicator-power ayatana-indicator-sound
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

(4) So, finally, I understand what is preventing the upgrade. Again as root:

apt-get remove ayatana-indicator-datetime ayatana-indicator-power ayatana-indicator-sound
apt-get autoremove --purge

(5) And now, finally, the upgrade is proceeding.

But why did I have to drop down to the command line to fix this? Why did the prompted upgrade just disappear without telling me anything?

Thanks, it helped me!!!!