Random idle time out Ubuntu Mate 16.04

Hello there! Would like to seek some inputs with regards to Mate’s (Ubuntu 16.04.4 LTS) behavior of having random idle time outs.

Problem: Observing idle timeout intervals of 10s, 20s, 30s, 40s randomly. “Dim display when idle” is ticked in the Mate Power Management Preferences.

Tshoot steps made:

Tried using “gsettings set org.gnome.settings-daemon.plugins.power idle-dim-time 60” but idle-dim-time is not initially listed from org.gnome.settings-daemon.plugins.power.gschema.xml (https://askubuntu.com/questions/98184/increase-screen-idle-dim-timeout)
Added idle-dim-time from the step above and initially applied 10s value but still getting random idle times
Edited via dconf editor GUI for newly added idle-dim-time but still has random idle times

All help would be highly appreciated!

Hi @jeydee,

is your system fully up-to-date?:


1 Like

Try another setting in Dconf editor: org, mate, power manager, idle dim time, change from default (10) to something greater, like 65. Let us know if this helps.


Currently using Mate Desktop 1.12.1 and will try updating to 1.20. Will certainly get back to this afterwards. :slight_smile:

Doesn’t seem to cut it for me. Played values of 40, 50, 55, 60, 65, 70 up to 100s. Not really sure of which “idle time” config to change to the system having one for gnome and one for mate (based from dconf).

Use the mate config as I outlined above. See if it works.

Upgrading to Mate 1.16.2 doesn’t seem to do the trick as well. Now when the machine goes idle and dims, idle times appear to be incrementing (current idle-time is 10s). My way to remove the idle state is by moving the cursor and the desktop goes out of idle state (screen brightens up). Next dim for the idle time out will be at 20s, 30s and so on.

Did that under the mater power manager. Setting a value of 65 yields an initial idle time value of 65 but as I move my mouse and wait for the next idle time, an approximate 130s (double of the first) was observed for the next idle time. Really confused which dconf entry or Mate desktop element should be configured for the fixed idle timing.

Hi jeydee,

I really can only say that I don’t personally use screen saver functions as they annoy me, apart from switching them off, I don’t have anything else to add to this thread; sorry!. :frowning: That said, you can try out 18.04, it is nearly finished and works well for me!. :smiley:

Well that’s a seemingly good option as well. Will sit for 16.04 until 18.04 LTS has been released for quite a while. Thanks btw!

1 Like

worked for me. thank you