RASPBERRY PI 2: Strange wifi interface naming


I am facing strange wifi interface naming.

Instead of eth0 I have enxb827eb676a76
Instead of wlan0 I have wlxc4e9841804d0 (usb dongle tp-link wn722n)
Instead of wlan1 I have wlxc4e9841f67e1 (usb dongle tp-link wn725n)
(all 3 are output from iwconfig)

I am currently using Ubuntu Mate 15.10. RPI 2.
I did not had this strange naming on Rasbian Jessie before.

Could you please let me know, if this is possible to change it somewhere into standard eth0, wlan0 or wlan1?
In fact, I dont have currently any problems with internet connection but I would like to try several tuturials for learning purposes (and everywhere wlan0 is used).

Thank you in advance.

Ive found that “something is renaming these interfaces”. Output from dmesg | grep wlan:

pi@pi:~$ dmesg | grep wlan
[    6.340198] r8188eu 1-1.2:1.0 wlxc4e9841f67e1: renamed from wlan0
[    9.917223] ath9k_htc 1-1.5:1.0 wlxc4e9841804d0: renamed from wlan0



I never could get any of the disable methods to work. YMMV

1 Like

To avoid having persistent interface names and revert back to the classic interface naming convention, simply add to the 1st command line in the file /boot/cmdline.txt the following keywords:

net.ifnames=0 biosdevname=0

Tip found in the UbuntuMATE Flavour FAQ :wink: