Raspberry pi 3 B+ doesn't boot


#1

Hi everone
I have a raspberry pi 3 B+ with (Intenso) micro SD HC Class 10 32GB card.I would like to try Ubuntu Mate on my raspberry pi system.I have downloaded https://ubuntu-mate.org/raspberry-pi/ubuntu-mate-16.04.2-desktop-armhf-raspberry-pi.img.xz file.Until now everthing goes well.But at the img writing I get some errors like underneath.I use the software for formating Gparted and img file writing Gnome-disk-utility 3.26.1.

error writing 1048576 bytes to offset 1004535808: Input/output error(g-io-error-quark, 0)

Im able to run Raspbian with out any trouble.Why doesn’t work with Ubuntu?

I also used fdisk and dd and ddrescue under commandline but raspberry pi couldn’t start or boot there were no green led its only flashing red led.I also added Screenshot underneath.
I also tried several times command line codes but it doesn’t boot either.

[CODE]sudo fdisk /dev/sdc
$ sudo fdisk /dev/sdc

Welcome to fdisk (util-linux 2.30.1).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Command (m for help): p
Disk /dev/sdc: 28,8 GiB, 30944526336 bytes, 60438528 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x02b4b86f

Device Boot Start End Sectors Size Id Type
/dev/sdc1 * 2048 60438527 60436480 28,8G b W95 FAT32

Command (m for help): d
Selected partition 1
Partition 1 has been deleted.

Command (m for help): n
Partition type
p primary (0 primary, 0 extended, 4 free)
e extended (container for logical partitions)
Select (default p): p
Partition number (1-4, default 1): 1
First sector (2048-60438527, default 2048):
Last sector, +sectors or +size{K,M,G,T,P} (2048-60438527, default 60438527):

Created a new partition 1 of type ‘Linux’ and of size 28,8 GiB.

Command (m for help): t
Selected partition 1
Hex code (type L to list all codes): b
Changed type of partition ‘Linux’ to ‘W95 FAT32’.

Command (m for help): a
Selected partition 1
The bootable flag on partition 1 is enabled now.

Command (m for help): w
The partition table has been altered.
Calling ioctl() to re-read partition table.
Syncing disks.

$ sudo mkfs -t vfat /dev/sdc1
mkfs.fat 4.1 (2017-01-24)

$ unxz ubuntu-mate-16.04.2-desktop-armhf-raspberry-pi.img.xz
[/code]

I tried both of them separate times

$ sudo dd bs=4M if=ubuntu-mate-16.04.2-desktop-armhf-raspberry-pi.img of=/dev/sdc status=progress conv=fsync
5000000000 bytes (5,0 GB, 4,7 GiB) copied, 774,045 s, 6,5 MB/s 
1192+1 records in
1192+1 records out
5000000000 bytes (5,0 GB, 4,7 GiB) copied, 812,327 s, 6,2 MB/s
$ sudo ddrescue -D --force ubuntu-mate-16.04.2-desktop-armhf-raspberry-pi.img /dev/sdc
GNU ddrescue 1.22
     ipos:    4999 MB, non-trimmed:        0 B,  current rate:   2224 kB/s
     opos:    4999 MB, non-scraped:        0 B,  average rate:   9057 kB/s
non-tried:        0 B,  bad-sector:        0 B,    error rate:       0 B/s
  rescued:    5000 MB,   bad areas:        0,        run time:      9m 11s
pct rescued:  100.00%, read errors:        0,  remaining time:         n/a
                              time since last successful read:         n/a
Finished                           

Thanks.


#2

The drivers haven’t been included yet. I was able to customize the images with this thread on the raspberrypi.org forums.

I made torrents of the images I made (or you could make your own with the information in the thread):


#3

Oh thanks a lot. I’m going to try it very soon.


#4

Oh my God. It works like a charm.Good Job!!!


#5

I’d be happy to host a mirror if someone would care to get me a copy without having to torrent it :stuck_out_tongue: