Raspberry Pi 7 inch Screen - Zoomed in / Too large?

Is there a way to make the raspberry pi screen not be so zoomed in when I use for example the welcome screen? I have the official screen and the pi 3

Do you mean change the font depth so everything is no longer scaled?

  • System → Preferences → Look & Feel → Appearance
  • “Fonts” tab
  • “Details…” button
  • Change the font resolution (dots per inch)

The default is 96 DPI. Welcome needs to be restarted to see it not zoomed in.

I dont see a details tab. Here is what for example welcome looks like on the official 7 inch screen.


Pic of no details tab
New photo by walkonatyclb

Ah, I see. The screen resolution seems to be low as it’s a small screen.

In which case, try increasing the screen resolution first if the monitor supports it - it’s under System → Preferences → Hardware → Monitors.

Because the window is larger then the screen, the “Details…” button was chopped off at the bottom.

Here is setting I can’t make any changes.


Looking at some details about the official Raspberry Pi screen, this seems to be a limitation of the display for technical reasons.

However, there is a trick you can do to nudge the window so you can change the font DPI, which may be your only hope:

Some windows in X are cut off at the side/bottom of the screen?

This is unfortunately a side-effect of many developers assuming a minimum screen resolution of 1024x768 pixels. You can usually reveal hidden buttons and fields by;

  • right clicking on the edge or top of the window,
  • picking "move"
  • using the up arrow key to nudge the window up off the top of the screen