Raspberry Pi fails to boot


I download ubuntu-mate-18.04.2-beta1-desktop-armhf+raspi-ext4 from https://ubuntu-mate.org/download/ and wrote the image via dd onto the smartcard.

I'm using a rasperry 3 B with arm7 cpu but the raspberry won't boot. The screen remains black, the green led is blinking now and then and nothing happens.

What image should I use? I need an ubuntu image.

Kind regards


Looks like a problem with the SD card, but it all depends what you mean by 'green led is blinking now and then' - is it regular about once every 2 seconds?
Can you check on the card content - especially the FAT partition?
Another possibility, which I think we can discount from your report, is that the system is trying to use a set of display options to which your monitor/TV doesn't respond.

I also tried another 16 GB SD-card with the same result. The cards are ok. I can read the vfat-partition containing system-boot on my workstation running Linuxmint. Also the writeable-partition (ext4).

Every other image (buster, ubuntu-server and so on) I write to the card is booting fast and without

Watching the green LED of the Raspberry now it does not blink. The raspi is up for five minutes now. The monitor is an ordinary 19" HDMI one.

Just now the green LED blinks again about less than one time a second, irregularly, and now it stops blinking again.

Don't know what's wrong. I downloaded the Image again and wrote it to card ten times or so because I thought maybe it's corrupted. Compared the checksums, all ok. The unzpped image is exactly 5,0 GB ( Bytes). I am wondering about that precise bytes indication showing a smooth integer.


My unzipped image shows as 4,882,813KB in file explorer - could that be significant?
I'm afraid, as one colour-blind to some extent, I'm no good on red led versus green led. I need positional info.
Having checked, the LED nearer the power socket (labelled PWR) commes on first, and stays on most the time, the LED further away (labelled ACT) comes on and off throughout the boot process.

Yes, could be siginifcant. When I calculate 4882813x1024 I get 5000000512 bytes. My image shows 5000000000 bytes. Maybe the image is defective?
The powerled is the one on the right side in red. It's constantly on while the raspberry is powered on. The green LED is the one left one. It's blinking during boot process and then now and then over 30 minutes but the screen remains dark.
I assume something is wrong with the image.

Who could check that?


OK, that sounds like it may well be booting, but no video shows.
If so, the config.txt in the FAT partition gives a possible route to success.
You can set it to force use of HDMI, and pick a group and mode which the monitor can handle - there's a lot of info in that file!
Unfortunately SSH is disabled initially, so you cannot get in from outside until you've booted and configured it.


Tried some different HDMI-settings in the config.txt all without success. Then I realized there is a DVI-HDMI adapter involved at the monitor.
I took the rasperry and connected it to a 22" real HDMI-monitor and emedialty have it on screen.

So it's that adapter that makes problems.

Let me thank you for your help and patience!


Interestingly enough other OS's like buster do not have a problem with that DVI-HDMI adapter and
show a screen when booting.


I've been using such an adapter with no problems for several years. I did have a DVI-HDMI cable which didn't work. I have settings in config.txt to get round lacks of EDID seen through the adapter, which use EDID settings in a file (created by me when connected by HDMI directly.

Setting hdmi_drive=1 Normal DVI mode did the trick.
Thank you for your efforts and the hint to the config.txt!
Got the thing running now.

Wish you a Merry Christmas!


Excellent - glad you got it sorted