Raspberry Pi file sharing

networking

#1

Ubuntu Mate is the only distribution I have tried on my new RPi, and I am impressed with how well it works. I wanted to get file sharing working with the Windows computers on my LAN. It was not trivial, so I thought I might share my experience for the potential benefit to others who wish to do such file sharing.

I installed the Synaptic Package Manager using

sudo apt-get install synaptic

since it handles package dependencies automatically.

Using it, I installed samba, samba-config, and cifs-utils.

I set my Workgroup name to “WORKGROUP” on my WIndows computers. Not wanting to deal with login hassles on my one-user network, I made my shares from Windows be available for “Everyone” with all permissions and I gave Everyone all capabilities.

samba-config would not run for me. I found the cure for that here:

After configuring some shared folders in samba-config, I could access them from Windows. However, when I tried to access a WIndows computer from Linux, I got “Failed to Retrieve Share List from Server.” I found a cure for that here: https://www.liberiangeek.net/2012/03/how-to-fix-failed-to-retrieve-share-list-from-server-in-ubuntu-12-04-11-10-when-file-sharing-with-windows/

So, in /etc/samba/smb.conf, I added the line

name resolve order = bcast host

as line 30 (after workgroup = WORKGROUP), and it all started working.


#2

I had to go through this again for 15.10. Still needed the blank /etc/libuser.conf file. I also made the change to /etc/samba/smb.conf, but I am not absolutely certain that it was still needed (snce I never saw the error message).

I did run into a new problem in that Samba kept insisting that I needed a password to get into the shares on my Windows 10 laptop; but I discovered that, by default, Windows asks for a password even when everyone is given access. I did not initially think of that because my Windows 8.1 desktop could see those shares without my having modiied that setting. (It may be that I was successful in submitting a password first time from the desktop.)


#3

If samba not open use sudo touch /etc/libuser.conf


#5

I’m not sure I get the point. How is this different in effect from the much earlier posted cure I quoted in my first post? Yeah, I know it is a bit easier than opening the editor; but I figured folks would know that, and I did not want to detract from the post by straycat_tim.


#6

Hi I entered the sudo apt-get install synaptic command in Terminal and ran, so how do you tell when its done running the last entry is Processing Triggers… and the cursor is still blinking, been blinking for 10 minutes now, so is it done or still running the command?

Where do I go to find Synaptic Package Manager if it is done running?

Thanks.


#7

After processing triggers has finished you’ll see your bash prompt with your name. yes, it can take a long time depending on how many dependencies it’s got to process and finalise. Patience :slight_smile:

It will be in administration I believe (someone correct me if I’m wrong) I don’t use GUI tools much.


#8

I had to go through this yet once again for 16.04. One important change is that the configuration GUI for Samba is no longer called samba-config. It is now system-config-samba. The blank /etc/libuser.conf file is still required, as is the change to /etc/samba/smb.conf (at least for me).