[Redmond layout bug] sometimes panel does not show open programs

Sometimes the Redmond panel does not show any of my open programs, it remains blank no matter what program I open.

-Ubuntu Mate 16.04 64bit
-changing panel layout using Mate tweak to ‘Ubuntu Mate’ then back to ‘Redmond’ fixes the issue
-logging out does not fix the issue
-I did not have this problem in Linux Mint Mate 17.3 (which uses Redmond layout by default)

Have not tested:
-how to reproduce, it was like this after I booted my desktop today (it also happened to my laptop before but I never tried to troubleshoot it)
-if this bug exists in other Ubuntu Mate versions
-if restarting the computer fixes the issue
-if the default ‘Ubuntu Mate’ layout has the same bug

Has anyone else experienced this bug?

Is it possible the applet for "window list" had been deleted on your panel somehow (particularly if it crashed and asked if you wanted to remove the applet).

One way to check is to right click near the bottom.

Otherwise, it would just present the panel options:

If you find a way to reproduce this, bug reports should be reported to Ubuntu MATE's Launchpad for the developer and maintainer to see.

I know this is a very old thread, but I didn't think starting a new one for the same issue was appropriate (but please let me know if that's the better way to go).

I'm having a very similar issue to the above. I just installed Mate 22.04.3 LTS and went about getting the interface to look like it did on my previous computer (running version 16.something). When I selected the Redmond panel in Tweak, the bar along the bottom went blank (just a black bar). I gave it a restart to see if it would help with no effect. I tried other panels and eventually came back to Redmond. Now it looks like it's mostly working, except it will not show any buttons for open folders or apps. The "docked" items to either side are there (Menu to the left and wifi, battery, and time to the right), but nothing ever shows up in the middle when I open something. Is there a way to reinstall the Redmond panel? It seems more like something went wrong than a bug.

Per the post above, a right-click on the bar shows this...

Many thanks for any help offered!



I think I've found out what the issue is. I discovered if I remove the icons I pinned to the right of the desktop button (below it was the Control Center, Brave, and DarkTable) the issue resolves itself.

Before (no open items showing)...

After (pinned icons removed and open items show up)...

So, a bit finicky, but not too bad.
Apologies for the false alarm. Hopefully this helps somebody else in the future.