Relationship between Boutique and APT

What is the relationship between Software Boutique and APT? IF it was not for the fact some users are having trouble with the new version of LibreOffice, I wouldn’t even know that there is a new version ready to upgrade to.

In Boutique I do see the Orange upgrade button ready to be clicked. But in Synaptic or in the Software Updater application, nothing is being reported. I noticed that the libre office PPA in boutique is not added to APT. Why?

This is terribly confusing and not very helpful. Most of us will be constantly gravitating between Boutique and Synaptic for our software needs. And Boutique doesn’t offer a shopping list of installed apps that we can quickly glance over and spot any new updates. We will have to go to each section in turn and scroll through the software.

Or is there something wrong with the way my system is currently working? Should I have got the LibreOffice upgrade notice on the Software Updater? Because if this is how Boutique is supposed to work (i.e. detached from APT) I’m afraid that will be a complete deal breaker and I will have to stop using Boutique.

The Software Boutique also uses apt to install applications. The option in the Software Boutique installs the libreoffice PPA. The wierd thing is that Synaptic uses the same sources. So an update in Software Boutique should also be visible in Synaptic.

Open a Terminal and do a sudo apt update does it than tell you that there are upgrades available?


I do get a few packages to upgrade when I do as you suggested. Strangely enough none of them show in the Software Updater, despite it regularly displaying other updates:

Here’s the output of apt list --upgradable after sudo apt update

Listing... Done
compiz/xenial-updates,xenial-updates 1: all [upgradable from: 1:]
compiz-core/xenial-updates 1: amd64 [upgradable from: 1:]
compiz-gnome/xenial-updates 1: amd64 [upgradable from: 1:]
compiz-mate/xenial-updates 1: amd64 [upgradable from: 1:]
compiz-plugins/xenial-updates 1: amd64 [upgradable from: 1:]
compiz-plugins-default/xenial-updates 1: amd64 [upgradable from: 1:]
gir1.2-unity-5.0/xenial-updates 7.1.4+16.04.20160701-0ubuntu1 amd64 [upgradable from: 7.1.4+15.10.20151002-0ubuntu2]
libcompizconfig0/xenial-updates 1: amd64 [upgradable from: 1:]
libdecoration0/xenial-updates 1: amd64 [upgradable from: 1:]
liblightdm-gobject-1-0/xenial-updates 1.18.2-0ubuntu2 amd64 [upgradable from: 1.18.2-0ubuntu1]
libunity-protocol-private0/xenial-updates 7.1.4+16.04.20160701-0ubuntu1 amd64 [upgradable from: 7.1.4+15.10.20151002-0ubuntu2]
libunity-scopes-json-def-desktop/xenial-updates,xenial-updates 7.1.4+16.04.20160701-0ubuntu1 all [upgradable from: 7.1.4+15.10.20151002-0ubuntu2]
libunity9/xenial-updates 7.1.4+16.04.20160701-0ubuntu1 amd64 [upgradable from: 7.1.4+15.10.20151002-0ubuntu2]
lightdm/xenial-updates 1.18.2-0ubuntu2 amd64 [upgradable from: 1.18.2-0ubuntu1]
linux-firmware/xenial-updates,xenial-updates 1.157.3 all [upgradable from: 1.157.2]
python3-distupgrade/xenial-updates,xenial-updates 1:16.04.15 all [upgradable from: 1:16.04.14]
python3-software-properties/xenial-updates,xenial-updates all [upgradable from:]
software-properties-common/xenial-updates,xenial-updates all [upgradable from:]
software-properties-gtk/xenial-updates,xenial-updates all [upgradable from:]
ubuntu-release-upgrader-core/xenial-updates,xenial-updates 1:16.04.15 all [upgradable from: 1:16.04.14]
ubuntu-release-upgrader-gtk/xenial-updates,xenial-updates 1:16.04.15 all [upgradable from: 1:16.04.14]

I’ve seen all of these for a while on Synaptic. I just never update from it, only from what the Software Updater tells me to. But in any case Libre Office doesn’t show here either.

Well, I went ahead and clicked the Libre Office Upgrade button on the Software Boutique. After it has done its thing, voilá; the PPA was added to Synaptic. Next time I ran the Software Updater, Libre Office was asking to be updated.

It was not clear to me that this is all I needed to do. I always ignored that orange button on the Libre Office entry at the Software Boutique. But now that I finally clicked it, I can’t really explain why it wasn’t obvious to me. It’s now patently obvious what that Libre Office entry on the Software Boutique is asking me to do, since Libre Office is already pre-installed by the system.

As for that list of upgradeable software on Synaptic, I went ahead and upgraded. I’m not sure why it was there and not on the Software Updater. But a few situations may have contributed to it:

  • I have automatic checking for updates turned off since I need to manage carefully my ISP data plan.
  • On several occasions, when my data plan is on the low end, I have ran the Software Updater, but dismissed any updates and asked it to remind me later.

Anyways, problems solved. All is well. I was being a bit dumb, but nothing I’m not used to :wink:

1 Like