Remove all panels

My respects to Everyone!
Can you tell me how to remove the panels at the top and bottom.
:grinning:

Welcome

Right click in open area in panel and select Delete this Panel.

Though you might want to go to Control Center / Mate Tweak / Panel and save just in case you change your mind.

d

1 Like

I have the upper one removed.
for the lower panel, it is not removed in this way - the button does not work.

Would you have screenshot of panel?
Is it a panel or a dock type?
In Mate Tweak try changing to a different layout and if successful at removing panel save as a Custom Layout.

Image shows Cupertino layout with Dock and Panel at top.


the delete button does not work.
probably this can be done with Dconf ?

I don't think you can delete the Gnome2 panel just custom panels. Did you click on the arrow next to it (Gnome2) and select another panel. Seems like you might be on ver 16? I'm on 22.04 and not familiar with panels available on your system.
Possible option might be to right click on panel / Properties / and check Autohide. This will pop up and allow access to menu. I have top and bottom always showing as didn't care for the pop up and down. Image shows this. The two items on top left are shown by Window List which is what I think is showing Mate Tweak in your screenshot.
p

1 Like

understood......
thank you very much.....

Hi @thr,

it is not that trivial to delete the last panel. You have to remove the panel from required components of your session.
Run gsettings get org.mate.session.required-components panel in your terminal. If the answer is mate-panel, then run gsettings set org.mate.session.required-components panel ''. This sets your panel key to empty string. Relogin after that.

Hope this helps.

1 Like
[email protected]:~$ gsettings get org.mate.session.required-components panel
'mate-panel'

gsettings set org.mate.session.required-components panel ''

1 Like

the panels disappeared....but now menu calls and application launches have stopped working

Holding off see Ironfoot is replying.

2 Likes

Application launchers work fine in my test setup. I am not running debian, however. To revert your changes, run gsettings set org.mate.session.required-components panel 'mate-panel'.

1 Like

i can also run it through the terminal.
I'll try using the hotkey somehow.
thank you very much.

1 Like