Rhythmbox no longer working on Ubuntu Mate 16.04

software

#1

My Rhythmbox stopped working last week, I am using Ubuntu Mate 16.04 powerpc on a Powerbook G4. I installed Ubuntu Mate 16.04 in June and it has been working well. I use Rhythmbox a lot and until today it worked fine.

Now, when I try to play anything I either get “Nothing to play” or " Cannot connect to Gstreamer, check your installation."

I have purged, and re-installed Rhythmbox and the same problems remain. The files will still play on Clementine but I prefer Rhythmbox.

I have also tried Banshee and Gnome Music, neither worked. Banshee froze, when I tried to import my music and Gnome Music just froze on the initial “Hey DJ” screen. Clementine continues to work as it always has but it is fussier about the files than Rhythmbox and harder to use.

This is the output when I run rhythmbox from the terminal:

$ rhythmbox

(rhythmbox:3696): Gtk-WARNING **: Duplicate child name in GtkStack: Add to Playlist

(rhythmbox:3696): Gtk-WARNING **: Duplicate child name in GtkStack: Add to Playlist

(rhythmbox:3696): Gtk-WARNING **: Duplicate child name in GtkStack: Add to Playlist

(rhythmbox:3696): Gtk-WARNING **: Duplicate child name in GtkStack: Add to Playlist

(rhythmbox:3696): Gtk-WARNING **: Duplicate child name in GtkStack: Add to Playlist

(rhythmbox:3696): Gtk-WARNING **: Duplicate child name in GtkStack: Add to Playlist

(rhythmbox:3696): Rhythmbox-WARNING **: Unable to grab media player keys: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SettingsDaemon was not provided by any .service files

Rhythmbox launches but media cannot be played and the error messages are given as above.

When I closed it, I got the following output:

(rhythmbox:3696): Rhythmbox-WARNING **: minus one
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

(rhythmbox:3696): Gtk-WARNING **: mnemonic “s” wasn’t removed for widget (0x1042fa18)

The output after running

apt-cache policy mate-settings-daemon{,-common} rhythmbox{,-data} librhythmbox-core9

is:

mate-settings-daemon:
Installed: 1.12.1-2build1
Candidate: 1.12.1-2build1
Version table:
*** 1.12.1-2build1 500
500 http://gb.ports.ubuntu.com/ubuntu-ports xenial/universe powerpc Packages
100 /var/lib/dpkg/status
mate-settings-daemon-common:
Installed: 1.12.1-2build1
Candidate: 1.12.1-2build1
Version table:
*** 1.12.1-2build1 500
500 http://gb.ports.ubuntu.com/ubuntu-ports xenial/universe powerpc Packages
100 /var/lib/dpkg/status
rhythmbox:
Installed: 3.3-1ubuntu7
Candidate: 3.3-1ubuntu7
Version table:
*** 3.3-1ubuntu7 500
500 http://gb.ports.ubuntu.com/ubuntu-ports xenial/main powerpc Packages
100 /var/lib/dpkg/status
rhythmbox-data:
Installed: 3.3-1ubuntu7
Candidate: 3.3-1ubuntu7
Version table:
*** 3.3-1ubuntu7 500
500 http://gb.ports.ubuntu.com/ubuntu-ports xenial/main powerpc Packages
100 /var/lib/dpkg/status
librhythmbox-core9:
Installed: 3.3-1ubuntu7
Candidate: 3.3-1ubuntu7
Version table:
*** 3.3-1ubuntu7 500
500 http://gb.ports.ubuntu.com/ubuntu-ports xenial/main powerpc Packages
100 /var/lib/dpkg/status

Is anyone else experiencing the same sort of problem on can offer any advice on how to fix it?


#2

This problem has been fixed by the last OS update. Rhythmbox is up and running again!


#3

But not for long, the exact same problem has come back! My son is using Ubuntu Mate on an Intel Macbook 1.1 and his Rhytmbox is working fine.