Right-ALT key not working in 24.04

I installed Ubuntu Mate 24.04 yesterday and all went well except my AltGr key seems dead. (I need it for all sorts of special characters I use for my job)

Oddly it works fine in Featherpad which is the only app on this machine that didn't come on the MATE ISO, but it is dead in Pluma, LibreOffice, Firefox, etc.


Welcome @Spider to the community!


Hi, @Spider :slight_smile:

I've tested just now the use of AltGr key combinations in an (Virtualbox) VM running a fresh install of Ubuntu MATE 24.04 LTS ("Noble Numbat") - the virtualization host machine is a laptop computer running Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") - and the "ALT GR" key combinations are working well for me in "Pluma", "LibreOffice Writer" and "Mozilla Firefox". For instance, pressing the ALT GR key together with the E key shows the € (Euro currency sign), as expected.


Additional information about my setup: in the "Keyboard" application (available by hovering over the "Ubuntu MATE Menu" -> "Preferences" -> "Keyboard"):

If I click on that "Keyboard" menu option, then the "Keyboard Preferences" window opens. If I then click on the "Layouts" tab of that window, I can see that I'm using a "Portuguese" keyboard layout and the "Keyboard Model" is a Generic 105-key PC":

Although the "Alt Gr" key combinations are working well for me in this Virtual Machine, this reminds me that I haven't yet completed the "Language Support" in this VM. So, if I go to the Ubuntu MATE Menu -> "Preferences" -> "Language Support":

... I then get a dialog box window warning me that "The language support is not installed completely":

So it may be a good idea to click on that "Install" button, which would prompt to enter out password:

... and, by doing that, the process of language support is completed:

@Spider : Maybe it's worth trying to check the "Language Support" in your case, complete it (if you haven't done that already), and then reboot to see if it helps in your case? As I've written, in my case, the "Alt Gr" key combinations were working well, even without completing the "Language Support", but I see no harm in trying to do that.

I hope this helps :slight_smile:


Thanks for your reply.

I installed language support and tried three different keyboard layouts, English, Spanish, and German, and the problem persists in all of them.

but the AltGr key mostly works in FeatherPad which is a QT based program (combinations like AltGr+Shift+E open the Edit menu for example).

I tried remapping the key with xmodmap but that didn't solve the problem either.

I am baffled.