Ripping DVD to ISO: libdvdread errors


#1

I am ripping my DVD collection to my file server, (menus and all, direct 1:1 copies, no transcoding), but I’m running into a bit of a problem. I had previously started this task on my Arch workstation, and was having good luck with dvdbackup, but then I shuffled some hardware around, sold the workstation, etc, and now the DVD drive is in a machine running Ubuntu Mate 18.04.

I previously used this process, which produced ISO files that VLC plays back with no problems.

  • dvdbackup gives me errors related to libdvdread, “cannot seek to block”
  • VLC has the same problem, terminal spew shows “cannot seek to block”
  • dd gives me input/output errors on some discs, others it doesn’t give me errors, but doesn’t copy anywhere near the entire disc. (~300MB of a 4+ GB disc)

I’ve ensured that libdvdcss2 is installed, I’ve followed the Ubuntu instructions here, I’ve tried mounting the disc, I’ve tried verifying packages using debsums, in case the install may have been corrupted, but so far no luck. I’m probably missing something that SHOULD have been a dependency, but wasn’t.

Any other things to check that I may have missed?


#2

Hi,

It must be copy protection scheme. You need the libdvdcss or libdvdcss2 (encrypted dvd), “sudo apt-get install ubuntu-restricted-extras” and “sudo apt-get install libdvdcss2”.


#3

That was something I had checked, actually, and I have both of those packages installed.

For those coming here from Google, I did finally find a workaround, and that is to play the disc with VLC, pause it, and then proceed to rip it, in which case all of my disks now rip perfectly.


#4

Hi,

This problem is strange, the solution found is stranger still. But… Glad you found a solution :slight_smile:


#5

It remains one of those “why does that make it work” mysteries for me… The only possible thing I can figure, is that analogous to mounting, VLC is somehow enabling decryption that is NOT happening when either ddrescue or dvdbackup runs without it. ¯_(ツ)_/¯


#6

Hi,

That must be it, some bug. Maybe it will be resolved in the next updates :slight_smile: