RPi 4 + Ubuntu Mate 20.10: when booting with no display, wifi is not working

I've a Raspberry Pi 4 (b) with Ubuntu Mate 20.10 running very well.
I've rigth configured the wifi wireless connection to my wireless network and it works OK

If I have plugged it to any display, it boots very well, mate desktop is loaded OK and the wifi wireless connection to my wireless network works OK

But If I boot it without display connection, the wireless connection is NOT brought up, so it does not connects to my wireless network.

It seems that the wifi wireless connection 'belongs' to the user that brings up the Desktop Xserver or something like that...

Any help please?

This happened to me too. Everything was working good. I've uploaded and upgrade it and then it tries to connect to my wifi and doesn't connect at all like it should, I shouldn't upgrade.....

Anyways, I turn my smartphone into a hostpot and it connects, but I want my WiFi -home connection again; you know.

1 Like

Hello. I have a similar problem with 20.10 64bit on RPi4 8GB
I had no issues with WiFi on 20.04.
Today I have tried for the first time the official image and, even though the WiFi (my phone hot-spot) was set up and recognised during first boot setup, it then disappeared after rebooting.
Now I am stuck since it appears that my user cannot even create / modify network connections.
Any idea how to fix this?

1 Like

This issue has plagued me for days I'm running a raspberry pie 400 with Ubuntu Mate version 2010. It will happily connect to the internet with my WI-fi hotspot.

When I use my home internet wi-fi, i cant get it to connect at all. It does work when use ubuntu 20.10 (The non Mate version).

Would be grateful for any help with this issue

1 Like

might have found a workaround.

I compared the wifi connection information between my working hotspot and my home wifi in:

/etc/NetworkManager/system-connections

I noticed that #permissions= had no in information in it
I gave it permissions

permissions=user: username here:;

Seems to have worked. Not sure if its a hack or when joining the home wifi, it just wont deal with the data propely no

1 Like

Doesn't appear to be working on my end. This is frustrating.

1 Like

Ok Took some messing around, but finally got wifi working. I disabled 5gtz in my router (not sue if I needed to) and created a wifi hotspot with phone.

Once i was one the web with my pie 400, i followed everything here and gt my wifi working

1 Like

One issue I have seen...upon first install, the WiFi list doesn't show my 5G network, only my 2G network - and a handful of others. Maybe I have too many active networks in the neighborhood?

The good news? If I type in the 5G network name under "hidden", it connects properly.

That actually worked. I run a Verizon G3100 FiOS router and disabling the 5GHz network started making my Ubuntu Mate 20.10 instance on the Pi4 working. I've seen this bizarre behavior as well with NetGear Wireless Range Extender EX6110. Coronavirus.