Samba Client connect to Share on Router's USB DIsk

I have an ASUS RT-AC56R router and it has a USB attached disk that I share on my local (home) network. The router has several ids/passwords set up and has associated them with Shares on the disk.

I have downloaded the Raspberry Pi version of Ubuntu-Mate 16.04 and have used the Get Started app to update the software and add Samba to the configuration. My Raspberry Pi is 2B and it is happily configured to my local network.

The network consists of the ASUS router and a Netgear Wireless repeater. The router is connected to the Charter cable modem (and the disk) and the repeater connects to the Raspberry Pi. Both the router and repeater are broadcasting the same SSID and use the same password for simplicities sake. The Pi is located in the basement and the strongest signal is from the repeater.

I have successfully connected to the disk on the router using Raspbian and mounting the folder to a place prepared in the Raspbian’s file structure. Here’s the command I used to do so:
sudo mount -t cifs -o user=pi,password=********,rw,file_mode=0700,dir_mode=0700 //192.168.1.1/public /home/pi/router/public

The above doesn’t work with Ubuntu-Mate. After thrashing around a bit doing some google searches, I also tried:
smbclient //rt-ac56r/public -U pi%*****

No joy. I got error messages from both complaining that the server does not support Extended_Security and more specifically that "client use spnego = yes and “client ntlvm2 auth = yes” were problems.

So my question is… How do I tell Ubuntu-Mate’s Samba that its ok to NOT use Extended_Security with this server? ( Like Raspbian is able to do. )

ldw

PS: As an aside: In my thrashing with google searches I found that many recommended turning guest mode on in the router. And when I do so, I can access the router’s directories with the Places->Network approach. This network is in my home so this may be an acceptable approach, but it seems like an inelegant way to do things and I’d prefer to use the mount command if possible.

1 Like

I doubt if Steve French made any changes to CIFS that would affect UM 16.04. On my system, CIFS is version 2.0.8 in kernel 4.4.0-45. You can see the version info with the modinfo command.

[email protected]:~$ modinfo cifs
filename:       /lib/modules/4.4.0-45-generic/kernel/fs/cifs/cifs.ko
version:        2.08
description:    VFS to access servers complying with the SNIA CIFS Specification e.g. Samba and Windows
license:        GPL
author:         Steve French <[email protected]>
alias:          fs-cifs
srcversion:     B427965EA8943914F8C691B
depends:        fscache
intree:         Y
vermagic:       4.4.0-45-generic SMP mod_unload modversions 
parm:           CIFSMaxBufSize:Network buffer size (not including header). Default: 16384 Range: 8192 to 130048 (uint)
parm:           cifs_min_rcv:Network buffers in pool. Default: 4 Range: 1 to 64 (uint)
parm:           cifs_min_small:Small network buffers in pool. Default: 30 Range: 2 to 256 (uint)
parm:           cifs_max_pending:Simultaneous requests to server. Default: 32767 Range: 2 to 32767. (uint)
parm:           enable_oplocks:Enable or disable oplocks. Default: y/Y/1 (bool)

The same command should work in Raspbian.

The mounting problem is usually related to permissions and/or differing UID numbers between the two systems.

AFAIK there are no configuration options in the kernel CIFS module related to EXTENDED_SECURITY.