Samba not using /etc/samba/smb.conf?

I have mate 16.04 I’m sure samba used to work fine, but recently it stopped taking any notice of what’s in /etc/samba/smb.conf. Previously when I browsed windows networks, it would use my settings to bring up my “pandc” work group and the shares on this computer. Now it just comes up with “WORKGROUP” and when I open that, it says, " HOME_NETWRORK_GAT". If I Double click that I get a warning, “Failed to retrieve share list from server: Connection refused”

I did a search for smb.conf and found another one in /usr/share/samba. That one was unmodified. So I thought I’d found the problem and set that up with my work group and shares. But still no difference.

So I did a “testparm” and got this

"mic[email protected]:~$ testparm
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The “syslog” option is deprecated
Processing section “[printers]”
Processing section “[print$]”
Processing section “[michael]”
Processing section “[stuff]”
Processing section “[mike]”
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions"

So I pressed enter and got all my shares, as expected.

Is the warning “the syslog is deprecated” relevant?

Has anybody got any clues what is going on here?

This line tells me that Samba successfully loaded your smb.conf file.

Can you show the content of this file?

Thanks orschiro. That’s the really frustrating thing, testparm is doing the right thing but going to windows network doesn’t.

Any way here’s the relevant parts of /etc/samba/smb.conf
(I tried pasting the whole thing, but the "#"s just make large bold font)

workgroup = PANDC

server string = %h server (Samba, Ubuntu)

dns proxy = no

 interfaces = 127.0.0.0/8 10.1.1.2/24
	hosts allow = 127.0.0.1 10.1.1.1/24

log file = /var/log/samba/log.%m

 max log size = 1000

syslog = 0

panic action = /usr/share/samba/panic-action %d

server role = standalone server

 passdb backend = tdbsam
	security = user
   obey pam restrictions = no

usershare allow guests = yes

comment = Home Directories

read only = no

create mask = 0775

directory mask = 0775

[printers]
   comment = All Printers
; browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = yes

[michael]
	path = /home/michael
	writeable = yes
	browseable = yes
	guest ok = yes
	comment = Mate

[stuff]
	path = /mnt/stuff
	writeable = yes
	browseable = yes
	guest ok = yes

[mike]
	path = /home/mike
	writeable = yes
	browseable = yes
	guest ok = yes

Woops, forgot to mention that I can see these shares on my other computer on the network. So yes samba is partly working. It’s exporting the shares fine but not showing the network locally.

Comment out syslog = 0, restart samba, testparm and you should not get the warning message.
I’m on UM16.04, samba is 4.3.11

So, that tells me at least that Samba is actually reading the contents of your config file. Otherwise, you wouldn’t be able to see your shares on the other machine…

Thanks pavlos that did get rid of the warning message, but hasn’t solved the problem.
I’m running same version as you.

orschiro, yes you’ve summed it up nicely.

I tried navigating to “pandc” directly from caja, ie,
smb://PANDC/
and got this message.

Could not display “smb://pandc/”.

Error: Failed to retrieve share list from server:
Connection refused
Please select another viewer and try again.

I’ll go and see if there’s anything in the logs.

Well, smbd logs look ok, but the nmbd logs don’t.
Could this be my problem?

[2017/05/24 13:13:03.755135, 0] …/source3/nmbd/nmbd_subnetdb.c:113(make_subnet)
nmbd_subnetdb:make_subnet()
Failed to open nmb socket on interface 10.1.1.2 for port 137. Error was Cannot assign requested address
[2017/05/24 13:13:03.755171, 0] …/lib/util/become_daemon.c:111(exit_daemon)
STATUS=daemon failed to start: NMBD failed when creating subnet lists, error code 13

woops just noticed the laptops smb.conf has the interfaces commented out, I’ll give that a try

Weird,
The modem says this computer is 10.1.1.44 and the laptop is 10.1.1.96
So I set
" interfaces = 127.0.0.0/8 10.1.1.2/24"
to
“interfaces = 127.0.0.0/8 10.1.1.44 10.1.1.96”
And it worked fine, but then I worried that the modem would assign different addresses.
Then I wondered how the laptop was working because I thought that had the same smb.conf.
When I checked all the addresses where commented out. So that’s what I’ve done on this and it’s now working fine.
Question is, is it more of a security risk now?
And why can’t nmbd make sense of “10.1.1.2/24” ?
I must admit I know very little about ip addresses, but from what I can make out 10.1.1.44 and 10.1.1.96 should fall into that range.