Samsung phone usb issues

Hi all,

I was wondering if anyone could help me solve a little problem. My wife has a samsung Galaxy S5 with soooooo many photos on it that it runs like a dog! So then she moans to me and says ‘i HATE my phone it’s so slow!!’ to which i adopt a super hero stance and reply ‘don’t worry wifey, i’ll sort it out’

Jump to me trying to transfer the images from her phone onto my laptop (which is running ubuntu MATE 15.04) and finding that it doesn’t even know that i’ve plugged the phone into the USB port!

Is there anyone out there who could help me get back to looking like a super hero instead of a muppet?

Many thanks, Matt

If you have a micro sd card adapter slot on your computer you can just take out the sd card and insert in into the computer and transfer files that way.

You might need to change the phone to hse PTP mode instead of MTP.

I also have some problems,but with connecting Motorola Moto g2. In Caja device is detected, but nothing is in (location for the device is mtp://[usb:001,005]/ )
I know it used to work on my other Xubuntu install, but that was before I upgraded to Android 6. Looking on some other forums I noticed:

Mass storage mode will not be possible in newer versions of Android. It was removed do to some security problems.

I understand that post is from 2014, but is it possible that there is another change going on?
Going trough “mass storage” options on Android 6, I can’t find any option to change the PTP/MTP settings.

I have an S5, connected it to UM, went to the phone settings (USB Computer Connection) selected PTP to share photos and I was able to see my photos and cp them to my drive.

I just found that after some rebooting of both computer and phone, I get notification icon where PTP option is available to select. Transfering files as we speak.