Scanner not working

Hi I recently installed the latest stable Ubuntu MATE 64 bit on my HP Model 17-x115dx. The printer I have is a Kodak all-in-one 55 XL Plus and it’s Linux compatible. It’s worked on other distros no prob. It’s printing fine and my printer is detected but when I go to scan it says no scanner is detected. I’ve installed different apps like sane and Xsane, and have tried to use simple scan but they all give me the same error. I downloaded the drivers from the Kodak website as they have Linux drivers for this printer but that still didn’t fix it. Any help is appreciated! I already searched the web and this forum but can’t seem to find a workable solution

I’ve recommended this on other posts… it’s pay for software, but you can try before you buy. It has worked on every scanner i’ve ever needed it to…it’s called VueScan… here’s the link.


Thanks I’ll give it a try after I’ve tried some other workarounds I just found

I tried downloading that VueScanner but its a tarball and I don’t know how to install it

extract the folder to your home directory, then run the binary file inside the folder. No other installation is needed.

What does the binary file look like? And how do I run it? Sorry I’m new at this

Here is a pic of my folder's the first icon that says just viewscan (it's purplish)..

Ok thank you so much for your help! I’ll give it a go!

Cool, it’s been awhile, the only other thing that may need to be done is, right click that icon and select properties. Goto permissions and make sure it’s executable.


Ok i did everything right but it’s not picking up my scanner so I guess mine isn’t supported. I’ve tried other workarounds but nothing is working. Might just have to go out and buy an HP all-in-one printer instead. They’re supposed to work and I think they’re supported by VueScan

If you know it’s linux compatible, does it means Kanon is providing drivers? If so, where?
How is the printer connecting to your computer?

Yes Kodak has the Linux drivers on its website and it’s connecting via USB

Ubuntu MATE comes by default with tlp. This is a power saving application that switch USB off after a time.
Edit /etc/default/tlp with root rights and set
default is 1
and save the file.

Enter the command lsusb in MATE-Terminal and find the row with your scanner.
There is an ID at the fifth column. The ID is separated by a : .
The first part of the ID before the : is the Vendor-ID.
The second part is the Product-ID.

Create an udev rule:
Create this file /etc/udev/rules.d/45-libsane.rules with root rights and add:
ATTRS{idVendor}==“Your-Vendor-ID(4 digits)”, ATTRS{idProduct}==“YourProduct-ID(4 digits)”, ENV{libsane_matched}=“yes”
ATTRS{idVendor}==“04a9”, ATTRS{idProduct}==“220d”, ENV{libsane_matched}=“yes”

and save the file.

Add your user to the groups scanner, lp and saned in a MATE-Terminal with sudo adduser your-user
sudo adduser your-user scanner
sudo adduser your-user lp
sudo adduser your-user saned

Than restart the computer.
Simple scan normally needs a few seconds to find scanner. Look at preferences. If the scanner is found try to scan.

Good luck!