Screen flash at startup 20.04

Hi,
For some time now, I have had a little problem at startup.
When the PC starts cold (turned off for at least a quarter of an hour), the desktop appears then the screen flashes (at least ten times or even twenty) as if it were looking for the display or resolution.
When it is warm or it restarts no problem, when I start with Windows, no problem. After that everything works perfectly.
That's why I dismissed a hardware problem (but you never know) and call on you.
I have an i5 7400 and an ASUS PRIME B250M-A motherboard with an SSD for root and Windows and an HDD for Home.
I run Ubuntu Mate and Windows 10 in dual boot.
A 27 inch screen HDMI.
HD Graphics 630 graphics card, driver used i915.
No worries until recently. The problem started with version 18.04.4 i think.
I installed the 20.04 thinking of fixing the problem and not...

I updated the BIOS recently, I use compiz but I try to desactivate it, it does not change anything.
I also use a command at startup to prevent the screen from going to sleep (xset -display: 0 s off -dpms) but even removed, the problem persists.
Thanks

Hi, i made a fresh install, same issue, is it a bug ?

Has anyone facing the same issue ?

This could be bug in your intel display hardware.
Maybe what I collected below could be of some use to you:


[https://www.intel.com/content/www/us/en/support/articles/000026580/graphics-drivers/graphics-for-7th-generation-intel-processors.html]

Problem: After turning on the PC the screen flickers even when using an HDMI connector.
Environment: Intel® HD Graphics 630


[https://wiki.archlinux.org/index.php/Intel_Graphics]

Screen flickering

Panel Self Refresh (PSR):
A power saving feature used by Intel iGPUs is known to cause flickering in some instances.
A temporary solution is to disable this feature using the kernel parameter i915.enable_psr=0


[https://www.dell.com/community/XPS/XPS-13-7390-Ubuntu-Screen-flickering/td-p/7430121]

Steps:

  1. sudo (editor command) /etc/default/grub

  2. Comment out this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

  1. Add this line instead:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0"

  1. Save and close your editor

  2. sudo update-grub

  3. reboot

Explanation:
Seems that starting with either the 5.2.0 or 5.3.0 kernel they decided to enable PSR (Panel Self Refresh) by default. Depending on the hardware, this periodic panel refreshing may cause the screen artifacts

-+-+-+-+
Good luck and let us know if it worked. :slight_smile:

1 Like

Hi Tkn, thank you for your response.

Hardware problem, not sure, no bug in BIOS or Windows 10.

Seems to be that but unfortunately the solution don’t solve the problem.
Another idea ?

What i’ve tried : i have another PC with ubuntu mate 20.04 and HDMI screen:

I switch screens and no problem, the both work well my pc with another screen and another pc with my screen !
The another pc uses the same pilot (i915), same resolution 1920x1080, 60Hz, the only difference is screen size, my screen is biger (27") the other is 23"
The problem is only with ubuntu on my PC + my screen...

I wonder why the monitor only has the issue when it is cold... that should not be happening.
There is definitely something wrong with that.
Also , the other monitor works.

What probably is happening is that this computer or this monitor is working slighly outside of specification. (I assume the HDMI cable is ok... is it ?) So it could be that the slightest deviation in refresh rate or output voltage could trigger this.

I'm not well enough versed in Intel video PLL circuitry programming to be of any help in this case.
I hope someone more knowledgable chimes in here to help you out.

If not, it is probably best if you file a bug against the Intel driver.
It may or may not be a bug but these GPU guys are friendly and it might possibly help you out.

I sended a bug rapport, waiting for an update or some other ideas.
Tkn, thanx again to spend time for my little problem.

I’ve tried a fresh install of 18.04.01 (linux kernel 4), problem is the same.

I don’t understand, when i was under this version, i don’t had the problem.

So i tried another HDMI cable, probleme’s still here.

Here's what I did to finish.

I left the PC on and turned off the screen for 15 minutes.

Turned on the screen, still the flash, the problem seems to come from him.

What I still do not understand is that the screen does not have the problem with Windows.

thanks a lot. this work for me perfectly