Screen Freezes and system becomes unresponsive


I have used Ubuntu mate for a while now but I have a problem every now and then (normally when I am playing minecraft) the screen just freezes. CTRL+ALT+Backspace does nothing this has happens with compiz and marco and with 15.10 and 16.04.

This is the laptop that I am useing:

the kern.log and the syslog both have errors here they are:


Thank you,

Please provide the output of:



Here it is

System: Host: NICK Kernel: 4.4.0-21-generic x86_64 (64 bit)
Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial
Machine: System: Acer (portable) product: Aspire ES1-512 v: V1.15
Mobo: Acer model: Aspire ES1-512 v: V1.15
Bios: Insyde v: V1.15 date: 07/20/2015
CPU: Quad core Intel Pentium N3540 (-MCP-) cache: 1024 KB
clock speeds: max: 2665 MHz 1: 1216 MHz 2: 1102 MHz 3: 940 MHz
4: 661 MHz
Graphics: Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Bay Trail GLX Version: 3.0 Mesa 11.2.0
Audio: Card Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network: Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
driver: ath9k
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169
Drives: HDD Total Size: 500.1GB (4.0% used)
ID-1: /dev/sda model: WDC_WD5000LPVX size: 500.1GB
ID-2: /dev/mmcblk0 model: N/A size: 4.0GB



I’m afraid it might be you’re victim of the horrible bug 109051.
Which is, well… Very ****** if that’s the case.

Ok thanks how do I set intel_idle.max_cstate=1 ?

and I have never had this problem with ubuntu(the normal one)

EDIT: nvm i found it

Note that max_cstate=1 is not a fix, just a workaround and that it has an extremely negative impact on your battery life.
(Because basically it tells the CPU never to go into low power mode)
There is something else I had some success with: setting an option in the i915 driver. You can do it by creating a file:

sudo nano /etc/modprobe.d/i915.conf

And writing inside:

options i915 modeset=1 enable_execlists=0

This might be worth a shot before going down the cstate route. I’ve had no freeze whatsoever in 3+Weeks, but it might be I’m just that lucky.


Ok I am trying that now.


this seems to have fixed it. I should know for sure in a day or two.

Thanks for your help


EDIT it just frose up i am going to try intel_idle.max_cstate=1

Hi @ParkerMC,

try a full system update which might help solve the problem?:

@wolfman I think you meant for me to run

sudo apt-get update && sudo apt-get dist-upgrade

and that did not fix it when I added intel_idle.max_cstate=1 and updated the grub it worked fine without freezing I think it is that bug in the kernel there were several people with the same CPU as me.


1 Like

Hi @ParkerMC,

you can also try running the following command:

sudo apt-get update && sudo apt-get dist-upgrade -f

The above will force any missing dependencies, restart if anything updates!.

Is it partially solved now?. :smiley:

I ran

and got:

Hit:1 xenial InRelease
Get:2 xenial-security InRelease [92.2 kB]
Hit:3 xenial InRelease
Get:4 xenial-updates InRelease [93.3 kB]
Hit:5 stable InRelease
Hit:6 xenial InRelease
Hit:7 xenial InRelease
Hit:8 xenial InRelease
Hit:9 xenial-backports InRelease
Hit:10 xenial InRelease
Hit:11 xenial InRelease
Fetched 185 kB in 2s (90.8 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Could iucode-tool be messing it up? I have never seen that until now


I have the N2940. It’s the same processor at a lower clock-speed. It’s running Ubuntu MATE 14.04 like a champ.

This won’t solve your problems in 16.04, but Trusty is a very good base if you want a stable computer. The 3.16 kernel in UM 14.04.2 is recent enough to handle touch-pad, screen brightness etc.

I think UM devs have done a fantastic job with 16.04. But the Xenial base still has rough edges.

1 Like

@mrtribute I think that might be what I have to do to get it working right without the short battery life. :frowning:

Yes I think UM team did a great job.

Hopefully the kernel bug will be fixed soon.

Thank you all,

1 Like

Updates seem to be broken as I cannot update using any method, all of them fail: Welcome, Terminal, Synaptic and changing my software sources download location to something else!. :thumbsdown:

Works fine for me.
I’m using

1 Like

Oui oui mon ami!, I will give the french channels a try!. :smiley: :thumbsup:

with intel_idle.max_cstate=1 it works just fine now.My battery life is still longer with UM(3-4 hours) than windows(2-3 hours).

Thank y’all for all your help,

1 Like

Hey mate. It seems some Ubuntu Kernel devs are on it (thank you lord!):

You can mark yourself as affected if you have a launchpad account using the link at the top of the post.


I will do that.